summaryrefslogtreecommitdiffstats
path: root/abs/extra/geoip
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-05 00:05:04 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-05 00:05:04 (GMT)
commit14a843531e558e77982ebb8efdeb887e8ef052b2 (patch)
tree543aefef66b7efbd3403b989bc832c6dfefe45c2 /abs/extra/geoip
parentaba3f508049afad2d51988c47c620adcc2e00981 (diff)
downloadlinhes_pkgbuild-14a843531e558e77982ebb8efdeb887e8ef052b2.zip
linhes_pkgbuild-14a843531e558e77982ebb8efdeb887e8ef052b2.tar.gz
linhes_pkgbuild-14a843531e558e77982ebb8efdeb887e8ef052b2.tar.bz2
geoip: update to 1.6.11
Diffstat (limited to 'abs/extra/geoip')
-rw-r--r--abs/extra/geoip/PKGBUILD38
1 files changed, 17 insertions, 21 deletions
diff --git a/abs/extra/geoip/PKGBUILD b/abs/extra/geoip/PKGBUILD
index 8e75a5e..806016a 100644
--- a/abs/extra/geoip/PKGBUILD
+++ b/abs/extra/geoip/PKGBUILD
@@ -1,24 +1,29 @@
-# $Id: PKGBUILD 158109 2012-05-03 01:01:32Z foutrelis $
-# Maintainer: Dan McGee <dan@archlinux.org>
+# $Id$
+# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
# Contributor: Manolis Tzanidakis <manolis@archlinux.org>
pkgname=geoip
-pkgver=1.4.8
-pkgrel=2
+pkgver=1.6.11
+pkgrel=1
pkgdesc="Non-DNS IP-to-country resolver C library & utils"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.maxmind.com/app/c"
license=('GPL')
depends=('zlib' 'geoip-database')
-backup=('etc/geoip/GeoIP.conf')
-options=('!libtool' '!emptydirs')
-source=(http://www.maxmind.com/download/geoip/api/c/GeoIP-$pkgver.tar.gz)
-sha256sums=('cf0f6b2bac1153e34d6ef55ee3851479b347d2b5c191fda8ff6a51fab5291ff4')
+optdepends=('geoip-database-extra: city/ASN databases (not needed for country lookups)')
+makedepends=('autoconf' 'libtool')
+options=('!emptydirs')
+source=($pkgname-$pkgver.tar.gz::https://github.com/maxmind/${pkgname}-api-c/archive/v${pkgver}.tar.gz)
+sha256sums=('8859cb7c9cb63e77f4aedb40a4622024359b956b251aba46b255acbe190c34e0')
+
+prepare() {
+ cd geoip-api-c-$pkgver
+ ./bootstrap
+}
build() {
- cd "$srcdir/GeoIP-$pkgver"
+ cd geoip-api-c-$pkgver
- autoreconf -vi
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
@@ -26,18 +31,9 @@ build() {
make
}
-check() {
- cd "$srcdir/GeoIP-$pkgver"
- make check
-}
-
package() {
- cd "$srcdir/GeoIP-$pkgver"
-
+ cd geoip-api-c-$pkgver
make DESTDIR="$pkgdir" install
-
- # country database is provided by geoip-database
- rm "$pkgdir/usr/share/GeoIP/GeoIP.dat"
}
# vim:set ts=2 sw=2 et: