summaryrefslogtreecommitdiffstats
path: root/abs/extra/google-chrome/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-07-15 23:35:44 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-07-15 23:35:44 (GMT)
commit6e07a7d48983b8b9192530eb5e1971589f01ce7d (patch)
treea57937993bcd378701476cd37e65eab7eaf07bb5 /abs/extra/google-chrome/PKGBUILD
parent1efdfcffe3c669abb6bfeaf60ad1b93aa780b5b0 (diff)
downloadlinhes_pkgbuild-6e07a7d48983b8b9192530eb5e1971589f01ce7d.zip
linhes_pkgbuild-6e07a7d48983b8b9192530eb5e1971589f01ce7d.tar.gz
linhes_pkgbuild-6e07a7d48983b8b9192530eb5e1971589f01ce7d.tar.bz2
google-chrome: 43.0.2357.134
Diffstat (limited to 'abs/extra/google-chrome/PKGBUILD')
-rw-r--r--abs/extra/google-chrome/PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/abs/extra/google-chrome/PKGBUILD b/abs/extra/google-chrome/PKGBUILD
index 66874ec..2374ca2 100644
--- a/abs/extra/google-chrome/PKGBUILD
+++ b/abs/extra/google-chrome/PKGBUILD
@@ -5,24 +5,27 @@
# or use: $ curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | awk -F\" '/pkgid/{ sub(".*-","",$4); print $4": "$10 }'
pkgname=google-chrome
-pkgver=43.0.2357.130
+pkgver=43.0.2357.134
pkgrel=1
pkgdesc="An attempt at creating a safer, faster, and more stable browser (Stable Channel)"
arch=('i686' 'x86_64')
url="https://www.google.com/chrome/index.html"
license=('custom:chrome')
depends=('alsa-lib' 'desktop-file-utils' 'flac' 'gconf' 'gtk2' 'harfbuzz' 'harfbuzz-icu' 'hicolor-icon-theme'
- 'icu' 'libcups' 'libpng' 'libxss' 'libxtst' 'nss' 'opus' 'snappy' 'speech-dispatcher' 'ttf-font' 'xdg-utils')
+ 'icu' 'libpng' 'libxss' 'libxtst' 'nss' 'opus' 'snappy' 'speech-dispatcher' 'ttf-font' 'xdg-utils')
optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
'ttf-liberation: fix fonts for some PDFs')
+makedepends=('pacman>=4.2.0')
provides=('google-chrome' 'pepper-flash')
options=('!emptydirs' '!strip')
install=$pkgname.install
_channel=stable
-_arch=amd64
-[[ $CARCH = i686 ]] && _arch=i386
-source=("google-chrome-${_channel}_${pkgver}_amd64.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_amd64.deb"
- 'eula_text.html')
+source=('eula_text.html')
+source_i686=("google-chrome-${_channel}_${pkgver}_i386.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_i386.deb")
+source_x86_64=("google-chrome-${_channel}_${pkgver}_amd64.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_amd64.deb")
+md5sums=('b7e752f549b215ac77f284b6486794b6')
+md5sums_i686=('9a806fa944c59ce398b13c8c79bca123')
+md5sums_x86_64=('b26558f6be7834d36a58e70348082203')
package() {
msg2 "Extracting the data.tar.lzma..."
@@ -57,5 +60,3 @@ package() {
msg2 "Rename google-chrome-stable to google-chrome..."
mv "$pkgdir"/usr/bin/google-chrome-stable "$pkgdir"/usr/bin/google-chrome
}
-md5sums=('b02492c9eb6131bb0a43cb8a906bd6e5'
- 'b7e752f549b215ac77f284b6486794b6')