summaryrefslogtreecommitdiffstats
path: root/abs/extra/google-chrome/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-09-21 21:44:44 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-09-21 21:44:44 (GMT)
commit7d56dcda529364e60504685ca16f0e284bb306c7 (patch)
treec674d284442ee24e3c45861f3f0d378d313312cb /abs/extra/google-chrome/PKGBUILD
parent307d3f0f2218af2ab2ec5d17b6efba93278eeed1 (diff)
downloadlinhes_pkgbuild-7d56dcda529364e60504685ca16f0e284bb306c7.zip
linhes_pkgbuild-7d56dcda529364e60504685ca16f0e284bb306c7.tar.gz
linhes_pkgbuild-7d56dcda529364e60504685ca16f0e284bb306c7.tar.bz2
google-chrome: update to 37.0.2062.120
Diffstat (limited to 'abs/extra/google-chrome/PKGBUILD')
-rw-r--r--abs/extra/google-chrome/PKGBUILD47
1 files changed, 27 insertions, 20 deletions
diff --git a/abs/extra/google-chrome/PKGBUILD b/abs/extra/google-chrome/PKGBUILD
index 987100f..a8906a0 100644
--- a/abs/extra/google-chrome/PKGBUILD
+++ b/abs/extra/google-chrome/PKGBUILD
@@ -5,52 +5,59 @@
# or use: $ curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | awk -F\" '/pkgid/{ sub(".*-","",$4); print $4": "$10 }'
pkgname=google-chrome
-pkgver=35.0.1916.114
+pkgver=37.0.2062.120
pkgrel=1
pkgdesc="An attempt at creating a safer, faster, and more stable browser (Stable Channel)"
arch=('i686' 'x86_64')
url="https://www.google.com/chrome"
license=('custom:chrome')
-depends=('alsa-lib' 'desktop-file-utils' 'flac' 'gconf' 'gtk2' 'harfbuzz' 'harfbuzz-icu' 'hicolor-icon-theme' 'icu'
- 'libgcrypt' 'libcups' 'libpng' 'libxss' 'libxtst' 'nss' 'opus' 'snappy' 'speech-dispatcher' 'ttf-font' 'xdg-utils')
+depends=('alsa-lib' 'desktop-file-utils' 'flac' 'gconf' 'gtk2' 'harfbuzz' 'harfbuzz-icu' 'hicolor-icon-theme'
+ 'icu' 'libcups' 'libpng' 'libxss' 'libxtst' 'nss' 'opus' 'snappy' 'speech-dispatcher' 'ttf-font' 'xdg-utils')
optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
'ttf-google-fonts-git')
-provides=("google-chrome=${pkgver}")
+provides=("google-chrome=$pkgver")
replaces=('chromium')
options=('!emptydirs' '!strip')
-install=${pkgname}.install
+install=$pkgname.install
_channel=stable
-_arch=i386
-[ "${CARCH}" = 'x86_64' ] && _arch=amd64
-source=("google-chrome-${_channel}_${pkgver}_${_arch}.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_${_arch}.deb")
-md5sums=('c4a88b4234f42c783441f760f5fc6070')
-[ "${CARCH}" = 'x86_64' ] && md5sums[0]='622a495960f247eca2f14eb2eccb5303'
+_arch=amd64
+[[ $CARCH = i686 ]] && _arch=i386
+source=("google-chrome-${_channel}_${pkgver}_$_arch.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_$_arch.deb"
+ 'eula_text.html')
+md5sums=('ad13b2cd986933a57cf348dc0efc50cf'
+ 'b7e752f549b215ac77f284b6486794b6')
+[[ $CARCH = i686 ]] && md5sums[0]='fc4fd42aa00222a7df9ad89417f8d219'
package() {
msg2 "Extracting the data.tar.lzma"
- bsdtar -xf data.tar.lzma -C "${pkgdir}/"
+ bsdtar -xf data.tar.lzma -C "$pkgdir/"
msg2 "Moving stuff in place"
# Icons
for i in 16 22 24 32 48 64 128 256; do
- install -Dm644 "${pkgdir}"/opt/google/chrome/product_logo_${i}.png \
- "${pkgdir}"/usr/share/icons/hicolor/${i}x${i}/apps/google-chrome.png
+ install -Dm644 "$pkgdir"/opt/google/chrome/product_logo_$i.png \
+ "$pkgdir"/usr/share/icons/hicolor/${i}x$i/apps/google-chrome.png
done
# Man page
- gzip "${pkgdir}"/usr/share/man/man1/google-chrome.1
+ gzip "$pkgdir"/usr/share/man/man1/google-chrome.1
# License
- install -d "${pkgdir}"/usr/share/licenses/google-chrome/
- curl -Ls https://www.google.com/intl/en/chrome/browser/privacy/eula_text.html \
- -o "${pkgdir}"/usr/share/licenses/google-chrome/eula_text.html
+ install -Dm644 eula_text.html "$pkgdir"/usr/share/licenses/google-chrome/eula_text.html
msg2 "Symlinking missing Udev lib"
- ln -s /usr/lib/libudev.so.1 "${pkgdir}"/opt/google/chrome/libudev.so.0
+ ln -s /usr/lib/libudev.so.1 "$pkgdir"/opt/google/chrome/libudev.so.0
+
+ msg2 "Fixing Chrome icon resolution"
+ _name=$(echo ${source/_*} | sed 's/.*/\u&/')
+ sed -i "/Exec=/i\StartupWMClass=$_name" "$pkgdir"/usr/share/applications/google-chrome.desktop
+
+ msg2 "Adding support for CHROMIUM_USER_FLAGS"
+ sed -i 's/ "$@"/"$CHROMIUM_USER_FLAGS" "$@"/' "$pkgdir"/opt/google/chrome/google-chrome
msg2 "Removing unnecessities (e.g. Debian Cron job)"
- rm -r "${pkgdir}"/etc/cron.daily/ "${pkgdir}"/opt/google/chrome/cron/
- rm "${pkgdir}"/opt/google/chrome/product_logo_*.png
+ rm -r "$pkgdir"/etc/cron.daily/ "$pkgdir"/opt/google/chrome/cron/
+ rm "$pkgdir"/opt/google/chrome/product_logo_*.png
msg2 "Rename google-chrome-stable to google-chrome"
mv "$pkgdir"/usr/bin/google-chrome-stable "$pkgdir"/usr/bin/google-chrome