summaryrefslogtreecommitdiffstats
path: root/abs/extra/google-chrome
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-03-17 17:18:29 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-03-17 17:18:29 (GMT)
commit3b506b542d0bc7c38dc242ed7ed387e829bf6bfb (patch)
treebdcf96c1cc39ab164ca068ca3b7742ef75b217e4 /abs/extra/google-chrome
parentd800300a8f72232ae1e3c4b4a60573db81f4aa3e (diff)
downloadlinhes_pkgbuild-3b506b542d0bc7c38dc242ed7ed387e829bf6bfb.zip
linhes_pkgbuild-3b506b542d0bc7c38dc242ed7ed387e829bf6bfb.tar.gz
linhes_pkgbuild-3b506b542d0bc7c38dc242ed7ed387e829bf6bfb.tar.bz2
google-chrome: update to 57.0.2987.110
Diffstat (limited to 'abs/extra/google-chrome')
-rw-r--r--abs/extra/google-chrome/PKGBUILD10
-rw-r--r--abs/extra/google-chrome/__changelog3
-rw-r--r--abs/extra/google-chrome/google-chrome-stable.sh2
3 files changed, 7 insertions, 8 deletions
diff --git a/abs/extra/google-chrome/PKGBUILD b/abs/extra/google-chrome/PKGBUILD
index dd9330f..0c3a393 100644
--- a/abs/extra/google-chrome/PKGBUILD
+++ b/abs/extra/google-chrome/PKGBUILD
@@ -5,7 +5,7 @@
# or use: $ curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | awk -F\" '/pkgid/{ sub(".*-","",$4); print $4": "$10 }'
pkgname=google-chrome
-pkgver=57.0.2987.98
+pkgver=57.0.2987.110
pkgrel=1
pkgdesc="An attempt at creating a safer, faster, and more stable browser (Stable Channel)"
arch=('x86_64')
@@ -22,9 +22,9 @@ _channel=stable
source=("google-chrome-${_channel}_${pkgver}_amd64.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_amd64.deb"
"$url/browser/privacy/eula_text.html"
'google-chrome-stable.sh')
-md5sums=('94fca0b7e96f2cce5d421ecebad04cbf'
+md5sums=('ba137093ddd19e643988e66d5821eb3d'
'SKIP'
- '99fa93d5e7fb5d622cef0f9621f3ffa3')
+ 'ed4cf73982461af7d0d944c1cbf9f4e8')
package() {
msg2 "Extracting the data.tar.xz..."
@@ -33,6 +33,7 @@ package() {
msg2 "Moving stuff in place..."
# Launcher
install -m755 google-chrome-$_channel.sh "$pkgdir"/usr/bin/google-chrome-$_channel
+ mv "$pkgdir"/usr/bin/google-chrome-$_channel "$pkgdir"/usr/bin/google-chrome
# Icons
for i in 16x16 22x22 24x24 32x32 48x48 64x64 128x128 256x256; do
@@ -52,7 +53,4 @@ package() {
msg2 "Removing Debian Cron job and duplicate product logos..."
rm -r "$pkgdir"/etc/cron.daily/ "$pkgdir"/opt/google/chrome/cron/
rm "$pkgdir"/opt/google/chrome/product_logo_*.png
-
- msg2 "Rename google-chrome-stable to google-chrome..."
- mv "$pkgdir"/usr/bin/google-chrome-stable "$pkgdir"/usr/bin/google-chrome
}
diff --git a/abs/extra/google-chrome/__changelog b/abs/extra/google-chrome/__changelog
index 672914a..cdc2677 100644
--- a/abs/extra/google-chrome/__changelog
+++ b/abs/extra/google-chrome/__changelog
@@ -1,3 +1,4 @@
Pull from ARU: https://aur.archlinux.org/packages/google-chrome/
- google-chrome.install: add symlink from /usr/bin/chromium to google-chrome so as not to break pkgs that use chromium
-- PKGBUILD: Rename google-chrome-stable to google-chrome"
+- PKGBUILD: Rename google-chrome-stable to google-chrome
+- google-chrome-stable.sh: add --no-first-run
diff --git a/abs/extra/google-chrome/google-chrome-stable.sh b/abs/extra/google-chrome/google-chrome-stable.sh
index e55c822..51c4220 100644
--- a/abs/extra/google-chrome/google-chrome-stable.sh
+++ b/abs/extra/google-chrome/google-chrome-stable.sh
@@ -6,4 +6,4 @@ if [[ -f ~/.config/chrome-flags.conf ]]; then
fi
# Launch
-exec /opt/google/chrome/google-chrome $CHROME_USER_FLAGS "$@" \ No newline at end of file
+exec /opt/google/chrome/google-chrome --no-first-run $CHROME_USER_FLAGS "$@"