summaryrefslogtreecommitdiffstats
path: root/abs/extra/google-chrome
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-03-20 22:11:28 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-03-20 22:11:28 (GMT)
commitae3af2ed004ffa8a99b9beac8d880f9a2aefe218 (patch)
treee1eb9b906deec9e80252da3cfd4a51d510726e00 /abs/extra/google-chrome
parentacca99b0f5c89cc3d5d9dc8df9df3d46282a338d (diff)
downloadlinhes_pkgbuild-ae3af2ed004ffa8a99b9beac8d880f9a2aefe218.zip
linhes_pkgbuild-ae3af2ed004ffa8a99b9beac8d880f9a2aefe218.tar.gz
linhes_pkgbuild-ae3af2ed004ffa8a99b9beac8d880f9a2aefe218.tar.bz2
google-chrome: update to 33.0.1750.152
Diffstat (limited to 'abs/extra/google-chrome')
-rw-r--r--abs/extra/google-chrome/PKGBUILD30
-rw-r--r--abs/extra/google-chrome/__changelog6
2 files changed, 17 insertions, 19 deletions
diff --git a/abs/extra/google-chrome/PKGBUILD b/abs/extra/google-chrome/PKGBUILD
index e47a6e0..3e18710 100644
--- a/abs/extra/google-chrome/PKGBUILD
+++ b/abs/extra/google-chrome/PKGBUILD
@@ -5,7 +5,7 @@
# or use: $ curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | awk -F\" '/pkgid/{ sub(".*-","",$4); print $4": "$10 }'
pkgname=google-chrome
-pkgver=32.0.1700.102
+pkgver=33.0.1750.152
pkgrel=1
pkgdesc="An attempt at creating a safer, faster, and more stable browser (Stable Channel)"
arch=('i686' 'x86_64')
@@ -15,45 +15,45 @@ depends=('alsa-lib' 'desktop-file-utils' 'flac' 'gconf' 'gtk2' 'harfbuzz' 'harf
'libgcrypt' 'libpng' 'libxss' 'libxtst' 'nss' 'opus' 'snappy' 'speech-dispatcher' 'ttf-font' 'xdg-utils')
optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
'ttf-google-fonts-git')
-provides=("google-chrome=$pkgver")
+provides=("google-chrome=${pkgver}")
conflicts=('google-chrome')
replaces=('chromium')
options=('!emptydirs' '!strip')
-install=$pkgname.install
+install=${pkgname}.install
_channel=stable
_arch=i386
-[ "$CARCH" = 'x86_64' ] && _arch=amd64
+[ "${CARCH}" = 'x86_64' ] && _arch=amd64
source=("google-chrome-${_channel}_${pkgver}_${_arch}.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_${_arch}.deb"
'https://www.google.com/intl/en/chrome/browser/privacy/eula_text.html')
-[ "$CARCH" = 'x86_64' ] && md5sums[0]='3f2cdc746980c7b9ac476ec013c80dfc'
-
-#PKGEXT='.pkg.tar'
+[ "${CARCH}" = 'x86_64' ] && md5sums[0]='305fda0487a3e0779d1fd2b4213be1cb'
package() {
msg2 "Extracting the data.tar.lzma"
- bsdtar -xf data.tar.lzma -C "$pkgdir/"
+ bsdtar -xf data.tar.lzma -C "${pkgdir}/"
msg2 "Moving stuff in place"
# Icons
for i in 16 22 24 32 48 64 128 256; do
- install -Dm644 "$pkgdir"/opt/google/chrome/product_logo_${i}.png "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/google-chrome.png
+ install -Dm644 "${pkgdir}"/opt/google/chrome/product_logo_${i}.png \
+ "${pkgdir}"/usr/share/icons/hicolor/${i}x${i}/apps/google-chrome.png
done
# Man page
- gzip "$pkgdir"/usr/share/man/man1/google-chrome.1
+ gzip "${pkgdir}"/usr/share/man/man1/google-chrome.1
# License
- install -Dm644 eula_text.html "$pkgdir"/usr/share/licenses/google-chrome/eula_text.html
+ install -Dm644 eula_text.html "${pkgdir}"/usr/share/licenses/google-chrome/eula_text.html
msg2 "Symlinking missing Udev lib"
- ln -s /usr/lib/libudev.so.1 "$pkgdir"/opt/google/chrome/libudev.so.0
+ ln -s /usr/lib/libudev.so.1 "${pkgdir}"/opt/google/chrome/libudev.so.0
msg2 "Removing unnecessities (e.g. Debian Cron job)"
- rm -r "$pkgdir"/etc/cron.daily/ "$pkgdir"/opt/google/chrome/cron/
- rm "$pkgdir"/opt/google/chrome/product_logo_*.png
+ rm -r "${pkgdir}"/etc/cron.daily/ "${pkgdir}"/opt/google/chrome/cron/
+ rm "${pkgdir}"/opt/google/chrome/product_logo_*.png
msg2 "Rename google-chrome-stable to google-chrome"
mv "$pkgdir"/usr/bin/google-chrome-stable "$pkgdir"/usr/bin/google-chrome
+
}
-md5sums=('3f2cdc746980c7b9ac476ec013c80dfc'
+md5sums=('305fda0487a3e0779d1fd2b4213be1cb'
'6d57da7476a4b1b7a81821d9c036425c')
diff --git a/abs/extra/google-chrome/__changelog b/abs/extra/google-chrome/__changelog
index 45a69e8..8e8830a 100644
--- a/abs/extra/google-chrome/__changelog
+++ b/abs/extra/google-chrome/__changelog
@@ -1,7 +1,5 @@
-1/23/14
Pull from ARU: https://aur.archlinux.org/packages/google-chrome/
-- PKGBUILD: comment out PKGEXT so we compress the pkg
- PKGBUILD: add replaces chromium
- google-chrome.install: add symlink from /usr/bin/chromium to google-chrome so as not to break pkgs that use chromium
-- Rename google-chrome-stable to google-chrome"
-- Change dep libgcrypt15 to libgcrypt
+- PKGBUILD: Rename google-chrome-stable to google-chrome"
+- PKGBUILD:Change dep libgcrypt15 to libgcrypt