summaryrefslogtreecommitdiffstats
path: root/abs/extra/gperftools
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-16 23:00:23 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-16 23:00:23 (GMT)
commit34e3c3f19af2ce74ef4361b691abae2c34df8398 (patch)
tree69fee86c4d223bd4178d2c10245533449d6bfc7e /abs/extra/gperftools
parentf791fb8677c31ebd7c9224e7659aef0eb3fb9875 (diff)
downloadlinhes_pkgbuild-34e3c3f19af2ce74ef4361b691abae2c34df8398.zip
linhes_pkgbuild-34e3c3f19af2ce74ef4361b691abae2c34df8398.tar.gz
linhes_pkgbuild-34e3c3f19af2ce74ef4361b691abae2c34df8398.tar.bz2
gperftools: initial inclusion. dep of leveldb
Diffstat (limited to 'abs/extra/gperftools')
-rw-r--r--abs/extra/gperftools/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/abs/extra/gperftools/PKGBUILD b/abs/extra/gperftools/PKGBUILD
new file mode 100644
index 0000000..fbdb440
--- /dev/null
+++ b/abs/extra/gperftools/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id$
+# Maintainer: Dave Reisner <dreisner@archlinux.org>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Thomas Jost <schnouki@schnouki.net>
+# Contributor: JaDa <jada@archlinux.us>
+# Contributor: Joaquim Pedro <osmano807@gmail.com>
+# Contributor: Jan Rüegg <rggjan@gmail.com>
+
+pkgname=gperftools
+pkgver=2.4
+pkgrel=2
+pkgdesc="Fast, multi-threaded malloc and nifty performance analysis tools"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/gperftools/"
+license=('BSD')
+depends=('perl')
+provides=('libtcmalloc.so'
+ 'libprofiler.so'
+ 'libtcmalloc_debug.so'
+ 'libtcmalloc_and_profiler.so'
+ 'libtcmalloc_minimal.so'
+ 'libtcmalloc_minimal_debug.so')
+optdepends=('graphviz: pprof graph generation'
+ 'gv: pprof postscript generation')
+source=("https://googledrive.com/host/0B6NtGsLhIcf7MWxMMF9JdTN3UVk/$pkgname-$pkgver.tar.gz")
+md5sums=('2171cea3bbe053036fb5d5d25176a160')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr --enable-frame-pointers
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: