summaryrefslogtreecommitdiffstats
path: root/abs/extra/graphite
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-09-19 18:09:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-09-19 18:09:12 (GMT)
commit43ef393b635a7da7511057ff72f1ac3d9c41925d (patch)
tree07fc9522041f08066522fe1ed158603104b568b2 /abs/extra/graphite
parentbf7ad0aef3cdad0fc0f4dae46763cce150ccc65d (diff)
downloadlinhes_pkgbuild-43ef393b635a7da7511057ff72f1ac3d9c41925d.zip
linhes_pkgbuild-43ef393b635a7da7511057ff72f1ac3d9c41925d.tar.gz
linhes_pkgbuild-43ef393b635a7da7511057ff72f1ac3d9c41925d.tar.bz2
remove chromium and deps.
rm deps graphite, harfbuzz, libwebp, opus, snappy, speech-dispatcher
Diffstat (limited to 'abs/extra/graphite')
-rw-r--r--abs/extra/graphite/PKGBUILD63
-rw-r--r--abs/extra/graphite/graphite2-1.2.0-cmakepath.patch9
2 files changed, 0 insertions, 72 deletions
diff --git a/abs/extra/graphite/PKGBUILD b/abs/extra/graphite/PKGBUILD
deleted file mode 100644
index 67fead2..0000000
--- a/abs/extra/graphite/PKGBUILD
+++ /dev/null
@@ -1,63 +0,0 @@
-# $Id$
-# Maintainer: AndyRTR <andyrtr@archlinux.org>
-
-pkgname=graphite
-pkgver=1.2.3
-pkgrel=1
-epoch=1
-arch=('i686' 'x86_64')
-url="http://projects.palaso.org/projects/graphitedev"
-pkgdesc='reimplementation of the SIL Graphite text processing engine'
-license=('LGPL' 'GPL' 'custom')
-depends=('gcc-libs')
-makedepends=('cmake' 'freetype2' 'python2')
- # - only for docs - target doesn't install properly
- # 'doxygen' 'texlive-latexextra' 'graphviz' 'asciidoc' 'perl-module-build' 'icu') # builds doc properly? 'texlive-helvetic' seems to be missing
-options=('!libtool' '!emptydirs')
-source=(http://downloads.sourceforge.net/project/silgraphite/graphite2/graphite2-${pkgver}.tgz
- graphite2-1.2.0-cmakepath.patch)
-md5sums=('7042305e4208af4c2d5249d814ccce58'
- '00353b67941dbc30b76a43253760769e')
-
-build() {
- cd "${srcdir}"
-
- # python2 fixes
- sed -i "s:\/usr\/bin\/python:\/usr\/bin\/python2:" graphite2-${pkgver}/tests/{jsoncmp,fuzztest,defuzz,corrupt.py}
-
- # fix install path - .cmake files contain architecture dependend content - patch taken from FC/Slackware
- pushd graphite2-${pkgver}
- patch -Np1 -i ${srcdir}/graphite2-1.2.0-cmakepath.patch
- popd
-
- mkdir build
- cd build
- cmake -G "Unix Makefiles" ../graphite2-${pkgver} \
- -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE:STRING=Release \
- -DGRAPHITE2_COMPARE_RENDERER=OFF \
- #-DCMAKE_VERBOSE_MAKEFILE:BOOL=ON # remove when docs install target will be fixed
-
- # fix unwanted -O3 cflag (taken form Debian)
- find . -type f ! -name "rules" ! -name "changelog" -exec sed -i -e 's/\-O3//g' {} \;
-
- make
- #make docs
-}
-
-check() {
- cd "${srcdir}"/build
- sed -i "s:python:python2:g" tests/CTestTestfile.cmake
- ctest
-}
-
-package() {
- cd "${srcdir}"/build
- # FIXME: all target doesn't install the docs target files
- make DESTDIR="$pkgdir/" install
-
- # licenses
- mkdir -p "${pkgdir}"/usr/share/licenses/${pkgname}
- install -m644 "${srcdir}"/graphite2-${pkgver}/COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/
-}
diff --git a/abs/extra/graphite/graphite2-1.2.0-cmakepath.patch b/abs/extra/graphite/graphite2-1.2.0-cmakepath.patch
deleted file mode 100644
index ee71cd6..0000000
--- a/abs/extra/graphite/graphite2-1.2.0-cmakepath.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff -urN graphite2-1.2.0.orig/src/CMakeLists.txt graphite2-1.2.0/src/CMakeLists.txt
---- graphite2-1.2.0.orig/src/CMakeLists.txt 2013-01-29 15:47:32.465841769 +0530
-+++ graphite2-1.2.0/src/CMakeLists.txt 2013-01-29 15:48:24.056843352 +0530
-@@ -136,4 +136,4 @@
-
-
- install(TARGETS graphite2 EXPORT graphite2 LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)
--install(EXPORT graphite2 DESTINATION share/graphite2 NAMESPACE gr2_)
-+install(EXPORT graphite2 DESTINATION lib${LIB_SUFFIX}/graphite2 NAMESPACE gr2_)