summaryrefslogtreecommitdiffstats
path: root/abs/extra/graphload
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/extra/graphload
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/extra/graphload')
-rw-r--r--abs/extra/graphload/PKGBUILD16
-rwxr-xr-xabs/extra/graphload/graphload.sh17
2 files changed, 0 insertions, 33 deletions
diff --git a/abs/extra/graphload/PKGBUILD b/abs/extra/graphload/PKGBUILD
deleted file mode 100644
index 6af2f95..0000000
--- a/abs/extra/graphload/PKGBUILD
+++ /dev/null
@@ -1,16 +0,0 @@
-pkgname=graphload
-pkgver=1
-pkgrel=1
-pkgdesc="command to graph the total CPU utilization for N-core systems for a given interval"
-depends=('gnuplot>=4.2.5')
-license='GPLv2'
-arch=('i686')
-
-build() {
- LH_ROOT=/usr/LH
- mkdir -p $startdir/pkg/$LH_ROOT/bin/
-
- cd $startdir
- # executables
- install -m0755 -D graphload.sh $startdir/pkg/$LH_ROOT/bin/
-}
diff --git a/abs/extra/graphload/graphload.sh b/abs/extra/graphload/graphload.sh
deleted file mode 100755
index 79023ec..0000000
--- a/abs/extra/graphload/graphload.sh
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-
-MYTICKS=100
-MYINTERVAL=4 # we sample once every $MYINTERVAL seconds
-MYINVERSEINTERVAL=0.25
-
-top -d $MYINVERSEINTERVAL -n $MYTICKS -b -i | grep Cpu | perl -e "while(<>) { split(','); \$load = 100 - substr @_[3], 0, -3; print \$load,\"\n\";}" > profile
-perl -e '$second=0; while(<>) { chop(); $load = $_; print "$second $load "; split " ", $load; print @_[0] + @_[1], "\n"; $second+=0.25;}' < profile > points
-echo "set grid
-set xrange [0: $(($MYTICKS/$MYINTERVAL))]
-set yrange [0: 101]
-set xtics 0,$MYINVERSEINTERVAL,$(($MYTICKS/$MYINTERVAL))
-set xlabel \"time\"
-set ylabel \"CPU usage\"
-plot \"points\" using 1:2 with lines title 'total load'
-replot" > gplot.cmds
-gnuplot -persist gplot.cmds