summaryrefslogtreecommitdiffstats
path: root/abs/extra/graphviz
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-20 03:55:41 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-20 03:55:41 (GMT)
commit3d521190982750f6b3d7bc58265a01b12789440f (patch)
tree337a1d8790a18a4066aec25860f3d6dc920232dc /abs/extra/graphviz
parent3d3a3a9a4ce6b4d7b00514c9463b502e17f91d6e (diff)
downloadlinhes_pkgbuild-3d521190982750f6b3d7bc58265a01b12789440f.zip
linhes_pkgbuild-3d521190982750f6b3d7bc58265a01b12789440f.tar.gz
linhes_pkgbuild-3d521190982750f6b3d7bc58265a01b12789440f.tar.bz2
graphviz: initial import for ruby
Diffstat (limited to 'abs/extra/graphviz')
-rw-r--r--abs/extra/graphviz/PKGBUILD42
-rw-r--r--abs/extra/graphviz/graphviz.install17
2 files changed, 59 insertions, 0 deletions
diff --git a/abs/extra/graphviz/PKGBUILD b/abs/extra/graphviz/PKGBUILD
new file mode 100644
index 0000000..f3de8b6
--- /dev/null
+++ b/abs/extra/graphviz/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 94713 2010-10-10 10:06:04Z andyrtr $
+# Maintainer: kevin <kevin@archlinux.org>
+# Contributor: John Proctor <jproctor@prium.net>
+
+pkgname=graphviz
+pkgver=2.26.3
+pkgrel=2
+pkgdesc="Creates acircular graph images"
+arch=('i686' 'x86_64')
+license=('CPL')
+depends=('gd>=2.0.35' 'librsvg>=2.22.3' 'libxaw>=1.0.5' 'ghostscript>=9.00')
+url="http://www.graphviz.org/"
+options=('!libtool')
+source=(${url}/pub/${pkgname}/stable/SOURCES/${pkgname}-${pkgver}.tar.gz)
+install=graphviz.install
+md5sums=('6f45946fa622770c45609778c0a982ee')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --without-gnomeui --docdir=/usr/share/doc/gvkp \
+ --disable-tcl --disable-sharp --disable-ruby --disable-python \
+ --disable-lua --disable-guile --disable-perl || return 1
+
+#--bindir=/bindir --libdir=/libdir --includedir=/includedir --mandir=/mandir \
+#--infodir=/infodir \
+#--docdir=/docdir --htmldir=/htmldir --dvidir=/dvidir \
+#--pdfdir=/pdfdir --psdir=/psdir
+
+ make || return 1
+}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+
+ #Fix a wrong file location for x86_64
+ rm -rf ${pkgdir}/usr/lib64
+
+ # Fix non-fhs doc files.
+ cd ${pkgdir}/usr/share
+ mkdir doc
+ mv graphviz/doc doc/graphviz
+}
diff --git a/abs/extra/graphviz/graphviz.install b/abs/extra/graphviz/graphviz.install
new file mode 100644
index 0000000..00510e3
--- /dev/null
+++ b/abs/extra/graphviz/graphviz.install
@@ -0,0 +1,17 @@
+# arg 1: the new package version
+post_install() {
+ # Create plugin config /usr/lib/graphviz/config6
+ rm -f usr/lib/graphviz/config{,6}
+ usr/bin/dot -c
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+# arg 1: the old package version
+pre_remove() {
+ rm -f usr/lib/graphviz/config{,6}
+}