summaryrefslogtreecommitdiffstats
path: root/abs/extra/graphviz
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-17 22:25:52 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-17 22:25:52 (GMT)
commitab648f0407c135e363b1977245e4c2c08004bfd0 (patch)
tree8ee16d886ce01fe50296fb7d3c6e6d62d44a12b0 /abs/extra/graphviz
parent2891a76e20dc9f7323b3fc2510c0ee1a3be51a84 (diff)
downloadlinhes_pkgbuild-ab648f0407c135e363b1977245e4c2c08004bfd0.zip
linhes_pkgbuild-ab648f0407c135e363b1977245e4c2c08004bfd0.tar.gz
linhes_pkgbuild-ab648f0407c135e363b1977245e4c2c08004bfd0.tar.bz2
graphviz: rebuild
Diffstat (limited to 'abs/extra/graphviz')
-rw-r--r--abs/extra/graphviz/PKGBUILD35
1 files changed, 15 insertions, 20 deletions
diff --git a/abs/extra/graphviz/PKGBUILD b/abs/extra/graphviz/PKGBUILD
index 2eb0135..852b018 100644
--- a/abs/extra/graphviz/PKGBUILD
+++ b/abs/extra/graphviz/PKGBUILD
@@ -5,16 +5,16 @@
pkgname=graphviz
pkgver=2.40.1
-pkgrel=1
+pkgrel=10
pkgdesc='Graph visualization software'
url='http://www.graphviz.org/'
license=('CPL')
-arch=('i686' 'x86_64')
-depends=('libltdl' 'gd' 'librsvg' 'libxaw' 'ghostscript' 'pango' 'gts')
-makedepends=('swig' 'mono' 'guile' 'lua51' 'ocaml' 'perl' 'python2' 'r' 'tk' 'qt4' 'gtk2')
+arch=('x86_64')
+depends=('libltdl' 'gd' 'librsvg' 'libxaw' 'ghostscript' 'pango' 'gts' 'gsfonts')
+makedepends=('swig' 'mono' 'guile' 'lua' 'ocaml' 'perl' 'python2' 'r' 'tk' 'qt4' 'gtk2')
optdepends=('mono: sharp bindings'
'guile: guile bindings'
- 'lua51: lua bindings'
+ 'lua: lua bindings'
'ocaml: ocaml bindings'
'perl: perl bindings'
'python2: python bindings'
@@ -23,10 +23,12 @@ optdepends=('mono: sharp bindings'
'qt4: gvedit'
'gtk2: gtk output plugin'
'xterm: vimdot')
-source=("${url}/pub/${pkgname}/stable/SOURCES/${pkgname}-${pkgver}.tar.gz"
+
+# http://www.graphviz.org/Download_source.php
+source=("https://graphviz.gitlab.io/pub/graphviz/stable/SOURCES/graphviz.tar.gz"
'ghostscript918.patch')
-sha1sums=('8a44d19bcdb50df1bd8e649de472ebf868468888'
- 'bcce75a535c277556e196638e59ea019b0a63fa1')
+sha256sums=('ca5218fade0204d59947126c38439f432853543b0818d9d728c589dfe7f3a421'
+ '0083d126e27f2223ec4226fc1d71c9c84106968a0fdf65de838aee1e4882bfdb')
install=install
@@ -37,10 +39,8 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- export CXXFLAGS+=' -Dint64=int64_t' # for ocaml
- export LIBPOSTFIX=/
export PYTHON=python2
- export LUA=lua5.1
+ export LIBPOSTFIX=/
./configure --prefix=/usr
make
@@ -50,13 +50,8 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- cd "${pkgdir}/usr/lib"
- install -d lua/5.1
- mv lua/gv.so lua/5.1
-
- # Workaround symlink upgrade bug (fixed in pacman trunk)
- # Also deduplicates the tcl libraries (upstream bug?)
- # Might have been this commit: https://github.com/ellson/graphviz/commit/f11aead
- rm -r tcl8.6/graphviz
- ln -s ../graphviz/tcl tcl8.6/graphviz
+ # Deduplicates TCL libraries
+ cd "${pkgdir}/usr/lib/tcl8.6"
+ rm -fr graphviz
+ ln -s ../graphviz/tcl graphviz
}