summaryrefslogtreecommitdiffstats
path: root/abs/extra/gst-plugins-base
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-12-26 19:34:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-12-26 19:34:27 (GMT)
commit4c865cf35a4205d73c5e40936e5fdc29a0360e68 (patch)
tree766a5c252d15ac241581208a9d8e944b0b756a30 /abs/extra/gst-plugins-base
parent4d17d1625762e29a53f44f4a9ffb185b2bca189c (diff)
downloadlinhes_pkgbuild-4c865cf35a4205d73c5e40936e5fdc29a0360e68.zip
linhes_pkgbuild-4c865cf35a4205d73c5e40936e5fdc29a0360e68.tar.gz
linhes_pkgbuild-4c865cf35a4205d73c5e40936e5fdc29a0360e68.tar.bz2
gst-plugins-base: initial inclusion.
dep of handbrake.
Diffstat (limited to 'abs/extra/gst-plugins-base')
-rw-r--r--abs/extra/gst-plugins-base/PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/abs/extra/gst-plugins-base/PKGBUILD b/abs/extra/gst-plugins-base/PKGBUILD
new file mode 100644
index 0000000..7fa8418
--- /dev/null
+++ b/abs/extra/gst-plugins-base/PKGBUILD
@@ -0,0 +1,54 @@
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgbase=gst-plugins-base
+pkgname=('gst-plugins-base-libs' 'gst-plugins-base')
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="GStreamer Multimedia Framework Base Plugins"
+arch=('i686' 'x86_64')
+license=('LGPL')
+makedepends=('pkgconfig' 'gstreamer' 'orc' 'libxv' 'alsa-lib' 'cdparanoia' 'libvisual' 'libvorbis' 'libtheora' 'pango' 'gobject-introspection')
+options=(!emptydirs)
+url="http://gstreamer.freedesktop.org/"
+source=(${url}/src/$pkgbase/$pkgbase-${pkgver}.tar.xz)
+sha256sums=('de2444a5c150d4e4b680364d7c0414cd8b015d95b305ff65d65a17683379532f')
+
+build() {
+ cd $pkgbase-$pkgver
+
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-static --enable-experimental \
+ --with-package-name="GStreamer Base Plugins (Arch Linux)" \
+ --with-package-origin="http://www.archlinux.org/"
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+
+ sed -e 's/^SUBDIRS_EXT =.*/SUBDIRS_EXT =/' -i Makefile
+}
+
+check() {
+ cd $pkgbase-$pkgver
+ # Testsuite fails on one test. Some refcount leak
+ make check
+}
+
+package_gst-plugins-base-libs() {
+ pkgdesc="GStreamer Multimedia Framework Base Plugin libraries"
+ depends=('gstreamer' 'orc' 'libxv')
+
+ cd $pkgbase-$pkgver
+ make DESTDIR="${pkgdir}" install
+}
+
+package_gst-plugins-base() {
+ depends=("gst-plugins-base-libs=$pkgver" 'alsa-lib' 'cdparanoia' 'libvisual' 'libvorbis' 'libtheora' 'pango')
+
+ cd $pkgbase-$pkgver
+ make -C gst-libs DESTDIR="${pkgdir}" install
+ make -C ext DESTDIR="${pkgdir}" install
+ make -C gst-libs DESTDIR="${pkgdir}" uninstall
+}