summaryrefslogtreecommitdiffstats
path: root/abs/extra/gst-plugins-base
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-08 13:28:08 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-08 13:28:08 (GMT)
commitc75d6a027b36eb87adecaa62f773e9f4dbe50404 (patch)
treec9117b0091753d0d2f1c8392bcc5d060d6e3b54c /abs/extra/gst-plugins-base
parent64d098ee7da575f85aa9cc45852385b2c77707c5 (diff)
downloadlinhes_pkgbuild-c75d6a027b36eb87adecaa62f773e9f4dbe50404.zip
linhes_pkgbuild-c75d6a027b36eb87adecaa62f773e9f4dbe50404.tar.gz
linhes_pkgbuild-c75d6a027b36eb87adecaa62f773e9f4dbe50404.tar.bz2
gst-plugins-base: update to 1.12.4
Diffstat (limited to 'abs/extra/gst-plugins-base')
-rw-r--r--abs/extra/gst-plugins-base/PKGBUILD64
-rw-r--r--abs/extra/gst-plugins-base/__changelog2
2 files changed, 44 insertions, 22 deletions
diff --git a/abs/extra/gst-plugins-base/PKGBUILD b/abs/extra/gst-plugins-base/PKGBUILD
index 7fa8418..229c36c 100644
--- a/abs/extra/gst-plugins-base/PKGBUILD
+++ b/abs/extra/gst-plugins-base/PKGBUILD
@@ -2,25 +2,45 @@
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgbase=gst-plugins-base
-pkgname=('gst-plugins-base-libs' 'gst-plugins-base')
-pkgver=1.2.1
+pkgname=(gst-plugins-base-libs gst-plugins-base)
+pkgver=1.12.4
pkgrel=1
pkgdesc="GStreamer Multimedia Framework Base Plugins"
-arch=('i686' 'x86_64')
-license=('LGPL')
-makedepends=('pkgconfig' 'gstreamer' 'orc' 'libxv' 'alsa-lib' 'cdparanoia' 'libvisual' 'libvorbis' 'libtheora' 'pango' 'gobject-introspection')
+url="https://gstreamer.freedesktop.org/"
+arch=(x86_64)
+license=(LGPL)
+makedepends=(gstreamer orc libxv iso-codes alsa-lib cdparanoia libvisual libvorbis libtheora pango
+ opus gobject-introspection autoconf-archive git pkgconfig)
+checkdepends=(gtk3 qt5-base)
options=(!emptydirs)
-url="http://gstreamer.freedesktop.org/"
-source=(${url}/src/$pkgbase/$pkgbase-${pkgver}.tar.xz)
-sha256sums=('de2444a5c150d4e4b680364d7c0414cd8b015d95b305ff65d65a17683379532f')
+_commit=e07c69f65598068b380753066783a1c67e3d4464 # tags/1.12.4^0
+source=("git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-base#commit=$_commit"
+ "gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common")
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd $pkgbase
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $pkgbase
+
+ git submodule init
+ git config --local submodule.common.url "$srcdir/gst-common"
+ git submodule update
+
+ NOCONFIGURE=1 ./autogen.sh
+}
build() {
- cd $pkgbase-$pkgver
+ cd $pkgbase
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --disable-static --enable-experimental \
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib \
--with-package-name="GStreamer Base Plugins (Arch Linux)" \
- --with-package-origin="http://www.archlinux.org/"
+ --with-package-origin="https://www.archlinux.org/" \
+ --enable-experimental --disable-static
# https://bugzilla.gnome.org/show_bug.cgi?id=655517
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
@@ -31,24 +51,24 @@ build() {
}
check() {
- cd $pkgbase-$pkgver
- # Testsuite fails on one test. Some refcount leak
+ cd $pkgbase
make check
}
package_gst-plugins-base-libs() {
pkgdesc="GStreamer Multimedia Framework Base Plugin libraries"
- depends=('gstreamer' 'orc' 'libxv')
+ depends=(gstreamer orc libxv iso-codes)
- cd $pkgbase-$pkgver
- make DESTDIR="${pkgdir}" install
+ cd $pkgbase
+ make DESTDIR="$pkgdir" install
}
package_gst-plugins-base() {
- depends=("gst-plugins-base-libs=$pkgver" 'alsa-lib' 'cdparanoia' 'libvisual' 'libvorbis' 'libtheora' 'pango')
+ depends=("gst-plugins-base-libs=$pkgver" alsa-lib cdparanoia libvisual libvorbis
+ libtheora pango opus)
- cd $pkgbase-$pkgver
- make -C gst-libs DESTDIR="${pkgdir}" install
- make -C ext DESTDIR="${pkgdir}" install
- make -C gst-libs DESTDIR="${pkgdir}" uninstall
+ cd $pkgbase
+ make -C gst-libs DESTDIR="$pkgdir" install
+ make -C ext DESTDIR="$pkgdir" install
+ make -C gst-libs DESTDIR="$pkgdir" uninstall
}
diff --git a/abs/extra/gst-plugins-base/__changelog b/abs/extra/gst-plugins-base/__changelog
new file mode 100644
index 0000000..95fcfd3
--- /dev/null
+++ b/abs/extra/gst-plugins-base/__changelog
@@ -0,0 +1,2 @@
+PKGBUILD: disable --enable-gtk-doc
+PKGBUILD: remove gtkdoc dep