summaryrefslogtreecommitdiffstats
path: root/abs/extra/gtk-doc
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-08 03:02:05 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-08 03:02:05 (GMT)
commit6be116bf9b86272e368491d7a5521dfff0386821 (patch)
tree028fc47d380d77f69015079579dac16ff34b009a /abs/extra/gtk-doc
parentcf731e50356a0e07b759713db1ed94352afb0890 (diff)
downloadlinhes_pkgbuild-6be116bf9b86272e368491d7a5521dfff0386821.zip
linhes_pkgbuild-6be116bf9b86272e368491d7a5521dfff0386821.tar.gz
linhes_pkgbuild-6be116bf9b86272e368491d7a5521dfff0386821.tar.bz2
gtk-doc: upgrade
Diffstat (limited to 'abs/extra/gtk-doc')
-rw-r--r--abs/extra/gtk-doc/PKGBUILD35
1 files changed, 20 insertions, 15 deletions
diff --git a/abs/extra/gtk-doc/PKGBUILD b/abs/extra/gtk-doc/PKGBUILD
index 3b07565..ec90190 100644
--- a/abs/extra/gtk-doc/PKGBUILD
+++ b/abs/extra/gtk-doc/PKGBUILD
@@ -1,23 +1,28 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: dorphell <dorphell@archlinux.org>
+# $Id: PKGBUILD 94104 2010-10-04 15:00:14Z ibiru $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
-pkgname=gtk-doc
+pkgname=gtk-doc
pkgver=1.15
-pkgrel=1
-options=('docs')
-pkgdesc="Used to document the public API of libraries"
-arch=(i686 x86_64)
+pkgrel=2
+pkgdesc="Documentation tool for public library API"
+arch=('any')
license=('GPL' 'FDL')
-depends=('perl>=5.8.8' 'rarian' 'docbook-xsl')
+depends=('docbook-xsl' 'gnome-doc-utils' 'perl')
makedepends=('pkgconfig' 'jade')
-install=gtk-doc.install
+optdepends=('jade: SGML support')
url="http://www.gtk.org/gtk-doc/"
source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('59cc73babf0db3a89d1a71f7ef5394a42ec1d3447d3a0a1539057a7b0ce44831')
-build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
- ./configure --prefix=/usr || return 1
- make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ export PYTHON=/usr/bin/python2
+ ./configure --prefix=/usr
+ make
}
-md5sums=('c022788b1fbbec30d55df4ccb34eeb90')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+