summaryrefslogtreecommitdiffstats
path: root/abs/extra/gtk3/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-20 21:33:23 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-20 21:33:23 (GMT)
commit48d52bfd8aa711b7e184124f238b2a3cea512318 (patch)
tree7d71bafb5a5e041af0d5472577efc17963a15209 /abs/extra/gtk3/PKGBUILD
parent680f7c2ee7d070528042dd3487f606da1b777241 (diff)
downloadlinhes_pkgbuild-48d52bfd8aa711b7e184124f238b2a3cea512318.zip
linhes_pkgbuild-48d52bfd8aa711b7e184124f238b2a3cea512318.tar.gz
linhes_pkgbuild-48d52bfd8aa711b7e184124f238b2a3cea512318.tar.bz2
gtk3: update to 3.18.6
Diffstat (limited to 'abs/extra/gtk3/PKGBUILD')
-rw-r--r--abs/extra/gtk3/PKGBUILD53
1 files changed, 41 insertions, 12 deletions
diff --git a/abs/extra/gtk3/PKGBUILD b/abs/extra/gtk3/PKGBUILD
index 5557008..15dc342 100644
--- a/abs/extra/gtk3/PKGBUILD
+++ b/abs/extra/gtk3/PKGBUILD
@@ -2,23 +2,34 @@
# Maintainer: Ionut Biru <ibiru@archlinux.org>
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-pkgname=gtk3
-pkgver=3.14.5
-pkgrel=1
-pkgdesc="GObject-based multi-platform GUI toolkit (v3)"
+pkgbase=gtk3
+pkgname=(gtk3 gtk-update-icon-cache)
+pkgver=3.18.6
+pkgrel=2
+pkgdesc="GObject-based multi-platform GUI toolkit"
arch=(i686 x86_64)
url="http://www.gtk.org/"
-install=gtk3.install
-depends=(atk cairo gtk-update-icon-cache libcups libxcursor libxinerama libxrandr libxi
+depends=(atk cairo libcups libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2
libxcomposite libxdamage pango shared-mime-info colord at-spi2-atk wayland libxkbcommon
- adwaita-icon-theme json-glib rest)
-makedepends=(gobject-introspection python2)
+ adwaita-icon-theme json-glib rest librsvg)
+makedepends=(gobject-introspection libcanberra)
license=(LGPL)
-source=(http://ftp.gnome.org/pub/gnome/sources/gtk+/${pkgver:0:4}/gtk+-$pkgver.tar.xz)
-sha256sums=('ba70f5ccde6646c6d8aa5a6398794b7bcf23fc45af22580a215d258f392dbbe2')
+source=(https://download.gnome.org/sources/gtk+/${pkgver:0:4}/gtk+-$pkgver.tar.xz
+ 0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
+ 0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
+ settings.ini)
+sha256sums=('78cabf0fd5a662f8723f62d5ac633072c76c557c1d700454c9c3deaa37e441ef'
+ '0402c3b7801810beb0f24ad20e4fb2eb7519cf3984f39e093a6e2752a0f7d9de'
+ '94722b06284e76f628fc8933617ac19c14f6775a5250fe3c382defab63d7b10e'
+ '01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202')
prepare() {
cd gtk+-$pkgver
+
+ # Fix zoom in/out cursors in GTK3 builds of Firefox
+ # https://bugzilla.gnome.org/show_bug.cgi?id=760141
+ patch -Np1 -i ../0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
+ patch -Np1 -i ../0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
}
build() {
@@ -27,7 +38,6 @@ build() {
CXX=/bin/false ./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --enable-gtk2-dependency \
--disable-schemas-compile \
--enable-x11-backend \
--enable-broadway-backend \
@@ -39,7 +49,26 @@ build() {
make
}
-package() {
+package_gtk3() {
+ depends+=(gtk-update-icon-cache)
+ optdepends=('libcanberra: gtk3-widget-factory demo')
+ install=gtk3.install
+
cd "gtk+-$pkgver"
make DESTDIR="$pkgdir" install
+ install -Dm644 ../settings.ini "$pkgdir/usr/share/gtk-3.0/settings.ini"
+
+ # split this out to use with gtk2 too
+ rm "$pkgdir/usr/bin/gtk-update-icon-cache"
}
+
+package_gtk-update-icon-cache() {
+ pkgdesc="GTK+ icon cache updater"
+ depends=(gdk-pixbuf2 hicolor-icon-theme)
+ install=gtk-update-icon-cache.install
+
+ cd gtk+-$pkgver/gtk
+ install -Dm755 gtk-update-icon-cache "$pkgdir/usr/bin/gtk-update-icon-cache"
+}
+
+# vim:set et sw=4: