summaryrefslogtreecommitdiffstats
path: root/abs/extra/gts
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-04 14:42:00 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-04 14:42:00 (GMT)
commit35cc5b31365d6873920ffa2b185fd7744f70f9a8 (patch)
tree2e6b6f519f9d3ef08c54005e78bb51ab01d99c7b /abs/extra/gts
parentf4b45adcd351f279480390487c5a8da126701dca (diff)
downloadlinhes_pkgbuild-35cc5b31365d6873920ffa2b185fd7744f70f9a8.zip
linhes_pkgbuild-35cc5b31365d6873920ffa2b185fd7744f70f9a8.tar.gz
linhes_pkgbuild-35cc5b31365d6873920ffa2b185fd7744f70f9a8.tar.bz2
gts: initial inclusion
Diffstat (limited to 'abs/extra/gts')
-rw-r--r--abs/extra/gts/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra/gts/PKGBUILD b/abs/extra/gts/PKGBUILD
new file mode 100644
index 0000000..b705a39
--- /dev/null
+++ b/abs/extra/gts/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id$
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Thomas Dziedzic <gostrc at gmail>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: Tobias Kieslich <tobias@justdreams.de>
+
+pkgname=gts
+pkgver=0.7.6
+pkgrel=3
+pkgdesc='Provides useful functions to deal with 3D surfaces meshed with interconnected triangles'
+url='http://gts.sourceforge.net/'
+license=('LGPL')
+arch=('i686' 'x86_64')
+depends=('glib2')
+source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('000720bebecf0b153eb28260bd30fbd979dcc040')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ export LDFLAGS=${LDFLAGS//--as-needed,}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}