summaryrefslogtreecommitdiffstats
path: root/abs/extra/gypsy/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-07 19:59:05 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-07 19:59:05 (GMT)
commitec7531c54115342f620a8246bd8179296bcd0048 (patch)
tree2abdc88259e6e0c1d1f62ce86d776a52fdfcd868 /abs/extra/gypsy/PKGBUILD
parent66c6eee906f1be419aec9deb833e378072922bbd (diff)
downloadlinhes_pkgbuild-ec7531c54115342f620a8246bd8179296bcd0048.zip
linhes_pkgbuild-ec7531c54115342f620a8246bd8179296bcd0048.tar.gz
linhes_pkgbuild-ec7531c54115342f620a8246bd8179296bcd0048.tar.bz2
gypsy: dep of qt5-location
Diffstat (limited to 'abs/extra/gypsy/PKGBUILD')
-rw-r--r--abs/extra/gypsy/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/extra/gypsy/PKGBUILD b/abs/extra/gypsy/PKGBUILD
new file mode 100644
index 0000000..fbb0c94
--- /dev/null
+++ b/abs/extra/gypsy/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Hans-Nikolai Viessmann <hv15@hw.ac.uk>
+# Contributor: Nuno Araujo <nuno.araujo@russo79.com>
+# Contributor: György Balló <ballogy@freestart.hu>
+
+pkgname=gypsy
+pkgver=0.9
+pkgrel=7
+pkgdesc="GPS multiplexing daemon"
+arch=(x86_64)
+url="https://gypsy.freedesktop.org/"
+license=(GPL)
+depends=(dbus-glib bluez bluez-libs libgudev)
+makedepends=(libxslt)
+source=("https://gypsy.freedesktop.org/releases/$pkgname-$pkgver.tar.gz"
+ g_type_init_deprecation.patch)
+md5sums=('e2d186df9c2cc3b70a027043e22acf1a'
+ 'f42f0bb01f8a278fce81d6f05305b9fb')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ patch -p1 -i ../g_type_init_deprecation.patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib/$pkgname
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+}