summaryrefslogtreecommitdiffstats
path: root/abs/extra/handbrake
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-04-24 16:45:00 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-04-24 16:45:00 (GMT)
commit17ac17bc0228bb66d4c36782f1ca15453042555a (patch)
tree48d6045a0ed8f6b1b66c9fd97dc36874cf801fe2 /abs/extra/handbrake
parente7c7bcc8e72ca2ceff29d3586ca75dad8f3dc176 (diff)
downloadlinhes_pkgbuild-17ac17bc0228bb66d4c36782f1ca15453042555a.zip
linhes_pkgbuild-17ac17bc0228bb66d4c36782f1ca15453042555a.tar.gz
linhes_pkgbuild-17ac17bc0228bb66d4c36782f1ca15453042555a.tar.bz2
handbrake: update to 1.0.7
Diffstat (limited to 'abs/extra/handbrake')
-rw-r--r--abs/extra/handbrake/PKGBUILD52
-rw-r--r--abs/extra/handbrake/handbrake-fix-missing-x265-link-flag.patch13
2 files changed, 17 insertions, 48 deletions
diff --git a/abs/extra/handbrake/PKGBUILD b/abs/extra/handbrake/PKGBUILD
index 3b0c3e4..bf66a04 100644
--- a/abs/extra/handbrake/PKGBUILD
+++ b/abs/extra/handbrake/PKGBUILD
@@ -4,52 +4,34 @@
# Contributor: Sebastien Piccand <sebcactus gmail com>
pkgname=('handbrake' 'handbrake-cli')
-pkgver=1.0.2
-pkgrel=1
+pkgver=1.0.7
+pkgrel=2
arch=('i686' 'x86_64')
url="https://handbrake.fr/"
license=('GPL')
-makedepends=('intltool' 'python2' 'yasm' 'wget' 'bzip2' 'gcc-libs' 'libnotify'
- 'gst-plugins-base' 'gtk3' 'dbus-glib' 'fribidi' 'libass' 'lame'
- 'fontconfig' 'freetype2' 'libxml2' 'libogg' 'libvorbis' 'cmake'
- 'libtheora' 'libsamplerate' 'ffmpeg' 'x264' 'libx264' 'x265'
- 'libvpx' 'libdvdnav' 'jansson' 'librsvg' 'libgudev')
-source=(https://handbrake.fr/mirror/HandBrake-$pkgver.tar.bz2
- handbrake-fix-missing-x265-link-flag.patch)
-sha256sums=('18e4563cc150309df03f7e73462b823ba2eca61644a7a536c9930611f3f9aa1e'
- '05e212e76b6e0b94a04de02cbeb7bf9db607059e19297b5bd3d0d143135285c4')
-
-prepare() {
- cd "$srcdir/HandBrake-$pkgver"
-
- # https://bugs.gentoo.org/show_bug.cgi?id=552792
- patch -Np1 -i ../handbrake-fix-missing-x265-link-flag.patch
-
- # Use more system libs
- # Bundled libbluray is kept because it is patched locally
- for _lib in ffmpeg x265 libvpx libdvdnav libdvdread; do
- sed -i "/MODULES += contrib\/$_lib/d" make/include/main.defs
- done
-}
+makedepends=('intltool' 'python2' 'yasm' 'wget' 'cmake' 'bzip2' 'gcc-libs'
+ 'zlib' 'libnotify' 'gst-plugins-base' 'gtk3' 'dbus-glib' 'libass'
+ 'lame' 'libxml2' 'opus' 'libvorbis' 'libtheora' 'libsamplerate'
+ 'x264' 'libx264' 'jansson' 'librsvg' 'libgudev')
+source=(https://handbrake.fr/mirror/HandBrake-$pkgver.tar.bz2)
+sha256sums=('ffdee112f0288f0146b965107956cd718408406b75db71c44d2188f5296e677f')
build() {
cd "$srcdir/HandBrake-$pkgver"
- ./configure \
- --prefix=/usr \
- --disable-gtk-update-checks
+ ./configure --prefix=/usr
make -C build
}
package_handbrake() {
pkgdesc="Multithreaded video transcoder"
- depends=('bzip2' 'gcc-libs' 'gst-plugins-base' 'libnotify' 'dbus-glib'
- 'fribidi' 'libass' 'lame' 'gtk3' 'fontconfig' 'freetype2' 'libxml2'
- 'libogg' 'libvorbis' 'libtheora' 'libsamplerate' 'ffmpeg' 'libx264'
- 'x265' 'libvpx' 'libdvdnav' 'jansson' 'librsvg' 'libgudev'
+ depends=('bzip2' 'gcc-libs' 'zlib' 'gst-plugins-base' 'libnotify' 'dbus-glib'
+ 'gtk3' 'libass' 'lame' 'libxml2' 'opus' 'libvorbis' 'libtheora'
+ 'libsamplerate' 'libx264' 'jansson' 'librsvg' 'libgudev'
'desktop-file-utils' 'hicolor-icon-theme')
optdepends=('gst-plugins-good: for video previews'
- 'gst-libav: for video previews')
+ 'gst-libav: for video previews'
+ 'libdvdcss: for decoding encrypted DVDs')
cd "$srcdir/HandBrake-$pkgver/build"
@@ -59,9 +41,9 @@ package_handbrake() {
package_handbrake-cli() {
pkgdesc="Multithreaded video transcoder (CLI)"
- depends=('bzip2' 'gcc-libs' 'zlib' 'fribidi' 'libass' 'lame' 'libxml2'
- 'libtheora' 'libsamplerate' 'ffmpeg' 'libx264' 'x265' 'libvpx'
- 'libdvdnav' 'jansson')
+ depends=('bzip2' 'gcc-libs' 'zlib' 'libass' 'lame' 'libxml2' 'opus'
+ 'libvorbis' 'libtheora' 'libsamplerate' 'libx264' 'jansson')
+ optdepends=('libdvdcss: for decoding encrypted DVDs')
cd "$srcdir/HandBrake-$pkgver/build"
install -D HandBrakeCLI "$pkgdir/usr/bin/HandBrakeCLI"
diff --git a/abs/extra/handbrake/handbrake-fix-missing-x265-link-flag.patch b/abs/extra/handbrake/handbrake-fix-missing-x265-link-flag.patch
deleted file mode 100644
index a963fe0..0000000
--- a/abs/extra/handbrake/handbrake-fix-missing-x265-link-flag.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Written by: Peter Foley <pefoley2@pefoley.com>
-Gentoo Bug: #552792
-
---- a/test/module.defs
-+++ b/test/module.defs
-@@ -25,6 +25,7 @@
-
- ifeq (1,$(FEATURE.x265))
- TEST.GCC.D += USE_X265
-+ TEST.GCC.l += x265
- endif
-
- TEST.GCC.l += $(foreach m,$(MODULES.NAMES),$($m.OSL.libs))