summaryrefslogtreecommitdiffstats
path: root/abs/extra/harfbuzz/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-02-19 18:16:16 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-02-19 18:16:16 (GMT)
commit8de064f6e96f960cdbfe6868d9957a4613f704df (patch)
tree4e73a420991733450d013529c0fee60e0365297a /abs/extra/harfbuzz/PKGBUILD
parent0374b16f1e15ba1819b62bd5a6e0076ac7b243d0 (diff)
parent6fde8cd5e74f0840e01988e743464fe91c0a28f8 (diff)
downloadlinhes_pkgbuild-8de064f6e96f960cdbfe6868d9957a4613f704df.zip
linhes_pkgbuild-8de064f6e96f960cdbfe6868d9957a4613f704df.tar.gz
linhes_pkgbuild-8de064f6e96f960cdbfe6868d9957a4613f704df.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/extra/harfbuzz/PKGBUILD')
-rw-r--r--abs/extra/harfbuzz/PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/abs/extra/harfbuzz/PKGBUILD b/abs/extra/harfbuzz/PKGBUILD
index c9f550f..1c066f1 100644
--- a/abs/extra/harfbuzz/PKGBUILD
+++ b/abs/extra/harfbuzz/PKGBUILD
@@ -3,24 +3,29 @@
pkgbase=(harfbuzz)
pkgname=(harfbuzz harfbuzz-icu)
-pkgver=0.9.19
+pkgver=0.9.36
pkgrel=1
pkgdesc="OpenType text shaping engine"
arch=(i686 x86_64)
url="http://www.freedesktop.org/wiki/Software/HarfBuzz"
license=(MIT)
-makedepends=(glib2 freetype2 graphite cairo icu)
-options=(!libtool)
+makedepends=(glib2 freetype2 graphite cairo icu gobject-introspection python2)
source=(http://www.freedesktop.org/software/harfbuzz/release/${pkgbase}-${pkgver}.tar.bz2)
-sha256sums=('d2da0f060d47f6ad9de8c8781bb21fa4b9eae8ea1cd1e956b814095baa002f35')
+sha256sums=('3bfbf7b016167ee6b2a2f83948fef75cc1253081873d6a91022161815956b9be')
build() {
cd $pkgbase-$pkgver
./configure --prefix=/usr \
- --with-glib --with-freetype --with-cairo --with-icu --with-graphite2
+ --with-glib --with-freetype --with-cairo --with-icu --with-graphite2 \
+ --with-gobject
make
}
+check() {
+ cd $pkgbase-$pkgver
+ make -k check || :
+}
+
package_harfbuzz() {
depends=(glib2 freetype2 graphite)
optdepends=('cairo: hb-view program')