summaryrefslogtreecommitdiffstats
path: root/abs/extra/hddtemp
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/extra/hddtemp
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/extra/hddtemp')
-rw-r--r--abs/extra/hddtemp/ChangeLog14
-rw-r--r--abs/extra/hddtemp/PKGBUILD39
-rw-r--r--abs/extra/hddtemp/hddtemp39
-rw-r--r--abs/extra/hddtemp/hddtemp.confd2
4 files changed, 94 insertions, 0 deletions
diff --git a/abs/extra/hddtemp/ChangeLog b/abs/extra/hddtemp/ChangeLog
new file mode 100644
index 0000000..d9b03e7
--- /dev/null
+++ b/abs/extra/hddtemp/ChangeLog
@@ -0,0 +1,14 @@
+2009-03-05 Andreas Radke <andyrtr@archlinux.org>
+* pkg moved to extra from AUR
+
+2008-01-23 Roman Kyrylych <roman@archlinux.org>
+* Updated to v38 of Debian's patchset
+
+2007-11-30 Roman Kyrylych <roman@archlinux.org>
+* Backup /etc/conf.d/hddtemp
+
+2007-11-09 Roman Kyrylych <roman@archlinux.org>
+* Updated to v37 of Debian's patchset
+
+2007-06-26 tardo <tardo@nagi-fanboi.net>
+* Built for x86_64
diff --git a/abs/extra/hddtemp/PKGBUILD b/abs/extra/hddtemp/PKGBUILD
new file mode 100644
index 0000000..996577d
--- /dev/null
+++ b/abs/extra/hddtemp/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id: PKGBUILD 29127 2009-03-05 18:08:55Z andyrtr $
+# Maintainer: Andrea Scarpino <bash@archlinux.it>
+# Contributor: Roman Kyrylych <roman@archlinux.org>
+# Contributor: Damir Perisa <damir@archlinux.org>
+
+pkgname=hddtemp
+pkgver=0.3.beta15.45
+_origver=0.3-beta15
+_patchver=45
+pkgrel=2
+pkgdesc="Gives you the temperature of your hard drive by reading S.M.A.R.T. information"
+arch=('i686' 'x86_64')
+url="http://www.guzu.net/linux/hddtemp.php"
+license=('GPL')
+depends=('glibc')
+backup=('etc/conf.d/hddtemp')
+source=(http://www.guzu.net/files/hddtemp-${_origver}.tar.bz2
+ http://ftp.debian.org/debian/pool/main/h/hddtemp/hddtemp_${_origver}-${_patchver}.diff.gz
+ 'hddtemp' 'hddtemp.confd')
+md5sums=('8b829339e1ae9df701684ec239021bb8'
+ 'a809a3a28d29ee719b2855af9b4eb1a8'
+ 'b7ebb86dfeef3bc4577ed1040307e36b'
+ 'fdca5c43900406f0be76534ef2a5a697')
+options=('!libtool')
+
+build() {
+ cd "$srcdir/$pkgname-${_origver}"
+
+ patch -Np1 -i "$srcdir/${pkgname}_${_origver}-${_patchver}.diff" || return 1
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --with-db-path=/usr/share/$pkgname/hddtemp.db
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+
+ install -D -m644 "$srcdir/$pkgname-${_origver}/debian/hddtemp.db" \
+ "$pkgdir/usr/share/${pkgname}/hddtemp.db" || return 1
+ install -D -m644 "$srcdir/hddtemp.confd" "$pkgdir/etc/conf.d/hddtemp" || return 1
+ install -D -m755 "$srcdir/hddtemp" "$pkgdir/etc/rc.d/hddtemp" || return 1
+}
diff --git a/abs/extra/hddtemp/hddtemp b/abs/extra/hddtemp/hddtemp
new file mode 100644
index 0000000..62f0908
--- /dev/null
+++ b/abs/extra/hddtemp/hddtemp
@@ -0,0 +1,39 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PARAMS=
+DRIVES=
+[ -f /etc/conf.d/hddtemp ] && . /etc/conf.d/hddtemp
+PID=$(pidof -o %PPID /usr/sbin/hddtemp)
+case "$1" in
+ start)
+ stat_busy "Starting HDDTemp"
+ [ -z "$PID" ] && /usr/sbin/hddtemp -d $PARAMS $DRIVES
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon hddtemp
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping HDDTemp"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon hddtemp
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 2
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+exit 0
diff --git a/abs/extra/hddtemp/hddtemp.confd b/abs/extra/hddtemp/hddtemp.confd
new file mode 100644
index 0000000..6a1e18e
--- /dev/null
+++ b/abs/extra/hddtemp/hddtemp.confd
@@ -0,0 +1,2 @@
+PARAMS="-q -l 127.0.0.1"
+DRIVES="/dev/sda"