summaryrefslogtreecommitdiffstats
path: root/abs/extra/help2man/help2man.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-10-19 18:31:38 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-10-19 18:31:38 (GMT)
commitd9aad8b00a9f3fb60e456c0e528df90189acb5b3 (patch)
tree6b9126d2336c62d1e5533798e7348f6a5723f6ba /abs/extra/help2man/help2man.install
parentd9a08ac22f9c6661cf3b478927be321274d10794 (diff)
parentc65b741914b31ac88086e363edc4415eb6aa1686 (diff)
downloadlinhes_pkgbuild-d9aad8b00a9f3fb60e456c0e528df90189acb5b3.zip
linhes_pkgbuild-d9aad8b00a9f3fb60e456c0e528df90189acb5b3.tar.gz
linhes_pkgbuild-d9aad8b00a9f3fb60e456c0e528df90189acb5b3.tar.bz2
Merge remote-tracking branch 'origin/testing' into testing
Conflicts: abs/core/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/extra/help2man/help2man.install')
-rw-r--r--abs/extra/help2man/help2man.install18
1 files changed, 18 insertions, 0 deletions
diff --git a/abs/extra/help2man/help2man.install b/abs/extra/help2man/help2man.install
new file mode 100644
index 0000000..ab6585b
--- /dev/null
+++ b/abs/extra/help2man/help2man.install
@@ -0,0 +1,18 @@
+info_dir=/usr/share/info
+info_files=(help2man.info)
+
+post_install() {
+ for f in ${info_files[@]}; do
+ install-info ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ for f in ${info_files[@]}; do
+ install-info --delete ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+ done
+}