summaryrefslogtreecommitdiffstats
path: root/abs/extra/hspell
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-12 19:19:00 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-12 19:19:00 (GMT)
commit999e36b77a1a58ffb1696ecf07bcf580a01acd43 (patch)
treeb35073c27719220e61a26dd51b5be68f6b9472f9 /abs/extra/hspell
parent19a9d6140dc01dd83f19526859e0768b7db2d8e7 (diff)
downloadlinhes_pkgbuild-999e36b77a1a58ffb1696ecf07bcf580a01acd43.zip
linhes_pkgbuild-999e36b77a1a58ffb1696ecf07bcf580a01acd43.tar.gz
linhes_pkgbuild-999e36b77a1a58ffb1696ecf07bcf580a01acd43.tar.bz2
hspell: update to 1.2.2
Diffstat (limited to 'abs/extra/hspell')
-rw-r--r--abs/extra/hspell/PKGBUILD60
1 files changed, 45 insertions, 15 deletions
diff --git a/abs/extra/hspell/PKGBUILD b/abs/extra/hspell/PKGBUILD
index 7700435..1b513e5 100644
--- a/abs/extra/hspell/PKGBUILD
+++ b/abs/extra/hspell/PKGBUILD
@@ -1,23 +1,53 @@
-# $Id: PKGBUILD 28768 2009-03-02 04:21:08Z eric $
+# $Id$
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
-pkgname=hspell
-pkgver=1.0
+pkgbase=hspell
+pkgname=('hspell' 'hunspell-he')
+pkgver=1.2
pkgrel=2
-pkgdesc="Hebrew spell-checker"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
license=('GPL')
url="http://www.ivrix.org.il/projects/spell-checker/"
-depends=('glibc>=2.7' 'zlib' 'perl')
-options=('!libtool' '!makeflags')
-source=(ftp://ftp.archlinux.org/other/hspell/${pkgname}-${pkgver}.tar.gz)
-md5sums=('3e12fa383c2cfd430918d115f33f9841')
+makedepends=('glibc' 'zlib' 'perl' 'hunspell' 'gawk')
+options=('!makeflags')
+source=(http://hspell.ivrix.org.il/${pkgname}-${pkgver}.tar.gz{,.sig})
+md5sums=('32fbc1a71e86ab46bf7870c6eec9a6be'
+ '858120037dd52ae823788518329ee7d3')
build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
- [ "${CARCH}" = "x86_64" ] && export CFLAGS="${CFLAGS} -fPIC"
- sed -i -e 's|/usr/bin/awk|/bin/awk|' wzip
- ./configure --prefix=/usr --enable-linginfo
- make || return 1
- make DESTDIR=${startdir}/pkg/ install || return 1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --enable-linginfo --enable-fatverb --enable-shared
+ make
+ make hunspell
+}
+
+package_hspell() {
+
+ pkgdesc="Hebrew spell-checker"
+ depends=('glibc' 'zlib' 'perl')
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ rm -f ${pkgdir}/usr/lib/libhspell.a
+}
+
+package_hunspell-he() {
+
+ pkgdesc="Hebrew hunspell dictionary"
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
+ install -dm755 ${pkgdir}/usr/share/hunspell
+ install -m644 he.dic ${pkgdir}/usr/share/hunspell/he_IL.dic
+ install -m644 he.aff ${pkgdir}/usr/share/hunspell/he_IL.aff
+
+ # the symlinks
+ install -dm755 ${pkgdir}/usr/share/myspell/dicts
+ pushd $pkgdir/usr/share/myspell/dicts
+ for file in $pkgdir/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/$(basename $file) .
+ done
+ popd
}