summaryrefslogtreecommitdiffstats
path: root/abs/extra/htop
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/extra/htop
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/extra/htop')
-rw-r--r--abs/extra/htop/ChangeLog8
-rw-r--r--abs/extra/htop/PKGBUILD28
-rw-r--r--abs/extra/htop/htop-treeview.patch12
3 files changed, 48 insertions, 0 deletions
diff --git a/abs/extra/htop/ChangeLog b/abs/extra/htop/ChangeLog
new file mode 100644
index 0000000..7d77d0b
--- /dev/null
+++ b/abs/extra/htop/ChangeLog
@@ -0,0 +1,8 @@
+2008-12-09 Alexander Fehr <pizzapunk gmail com>
+
+ * htop-0.8.1-1:
+ New upstream release.
+ New maintainer.
+ Added patch to fix FS#12235.
+ Enabled Unicode support.
+ Added ChangeLog.
diff --git a/abs/extra/htop/PKGBUILD b/abs/extra/htop/PKGBUILD
new file mode 100644
index 0000000..326a98a
--- /dev/null
+++ b/abs/extra/htop/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 21081 2008-12-09 17:41:11Z alexanderf $
+# Maintainer: Alexander Fehr <pizzapunk gmail com>
+
+pkgname=htop
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="Interactive process viewer"
+arch=('i686' 'x86_64')
+url="http://htop.sourceforge.net/"
+license=('GPL')
+depends=('ncurses')
+options=('!emptydirs')
+source=(http://downloads.sourceforge.net/htop/htop-$pkgver.tar.gz
+ htop-treeview.patch)
+md5sums=('f0b259ca29175656de48bf0fa0a2e619'
+ '54613e5237592691da8903fae05780d9')
+
+build() {
+ cd "$srcdir/htop-$pkgver"
+
+ # Fix tree view
+ # http://sourceforge.net/tracker2/?func=detail&aid=2343835&group_id=108839&atid=651635
+ patch -Np1 -i "$srcdir/htop-treeview.patch" || return 1
+
+ ./configure --prefix=/usr --enable-unicode || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
diff --git a/abs/extra/htop/htop-treeview.patch b/abs/extra/htop/htop-treeview.patch
new file mode 100644
index 0000000..bcf6334
--- /dev/null
+++ b/abs/extra/htop/htop-treeview.patch
@@ -0,0 +1,12 @@
+diff -ur htop-0.8.1.orig/ProcessList.c htop-0.8.1/ProcessList.c
+--- htop-0.8.1.orig/ProcessList.c 2008-09-23 08:23:14.000000000 +0200
++++ htop-0.8.1/ProcessList.c 2008-12-09 15:14:56.000000000 +0100
+@@ -331,7 +331,7 @@
+
+ for (int i = Vector_size(this->processes) - 1; i >= 0; i--) {
+ Process* process = (Process*) (Vector_get(this->processes, i));
+- if (process->tgid == pid || (process->tgid == process->pid && process->ppid == pid)) {
++ if (process->tgid == pid || process->ppid == pid) {
+ Process* process = (Process*) (Vector_take(this->processes, i));
+ Vector_add(children, process);
+ }