summaryrefslogtreecommitdiffstats
path: root/abs/extra/hunspell
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-14 18:14:18 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-14 18:14:18 (GMT)
commit044f02c37b8430e180310e741256ee44eac3d410 (patch)
tree1617535eaf970498317c42163c92207b7d98b807 /abs/extra/hunspell
parent20318531c85fa10c8ddca273ad7e818bccf7ebd7 (diff)
downloadlinhes_pkgbuild-044f02c37b8430e180310e741256ee44eac3d410.zip
linhes_pkgbuild-044f02c37b8430e180310e741256ee44eac3d410.tar.gz
linhes_pkgbuild-044f02c37b8430e180310e741256ee44eac3d410.tar.bz2
hunspell: update to 1.6.2
Diffstat (limited to 'abs/extra/hunspell')
-rw-r--r--abs/extra/hunspell/PKGBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/abs/extra/hunspell/PKGBUILD b/abs/extra/hunspell/PKGBUILD
index 89f9c87..2b08c38 100644
--- a/abs/extra/hunspell/PKGBUILD
+++ b/abs/extra/hunspell/PKGBUILD
@@ -3,26 +3,36 @@
# Contributor: Hussam Al-Tayeb <ht990332@gmail.com>
pkgname=hunspell
-pkgver=1.3.3
+pkgver=1.6.2
pkgrel=1
pkgdesc="Spell checker and morphological analyzer library and program"
-arch=('i686' 'x86_64')
-url="http://hunspell.sourceforge.net/"
+arch=('x86_64')
+url="https://hunspell.github.io/"
license=('GPL' 'LGPL' 'MPL')
depends=('gcc-libs' 'readline')
optdepends=('perl: for ispellaff2myspell')
-source=(http://downloads.sourceforge.net/hunspell/hunspell-$pkgver.tar.gz)
-md5sums=('4967da60b23413604c9e563beacc63b4')
+source=($pkgname-$pkgver.tar.gz::https://github.com/hunspell/hunspell/archive/v${pkgver}.tar.gz)
+sha256sums=('3cd9ceb062fe5814f668e4f22b2fa6e3ba0b339b921739541ce180cac4d6f4c4')
+
+prepare() {
+ cd hunspell-$pkgver
+ autoreconf -vfi
+}
build() {
- cd "$srcdir/hunspell-$pkgver"
+ cd hunspell-$pkgver
./configure --prefix=/usr --disable-static \
- --with-ui --with-readline --with-experimental
+ --with-ui --with-readline # --with-experimental breaks build in this release
make
}
+check() {
+ cd hunspell-$pkgver
+ make check
+}
+
package() {
- cd "$srcdir/hunspell-$pkgver"
+ cd hunspell-$pkgver
make DESTDIR="$pkgdir" install
# add generic hunspell.so for development and projects not using pkgconfig flags - FS#30592