summaryrefslogtreecommitdiffstats
path: root/abs/extra/hyphen
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
commit5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (patch)
treef13051093a52f47f5954c2ee2a783bc2f0f62f96 /abs/extra/hyphen
parent8d35f28049488f2585ef765bf48e7a58958fd587 (diff)
parent04697136037cb5341ee6c051f8aaa265c0400c82 (diff)
downloadlinhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.zip
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.gz
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/extra/hyphen')
-rw-r--r--abs/extra/hyphen/PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/abs/extra/hyphen/PKGBUILD b/abs/extra/hyphen/PKGBUILD
new file mode 100644
index 0000000..2033af4
--- /dev/null
+++ b/abs/extra/hyphen/PKGBUILD
@@ -0,0 +1,56 @@
+# $Id$
+# Maintainer: AndyRTR <andyrtr@archlinux.org>
+
+pkgbase=hyphen
+pkgname=('hyphen' 'hyphen-en')
+pkgver=2.8.8
+pkgrel=1
+arch=('x86_64')
+url="http://hunspell.sf.net"
+license=('GPL2' 'LGPL2.1' 'MPL')
+makedepends=('glibc' 'perl')
+source=(http://downloads.sourceforge.net/hunspell/${pkgname}-${pkgver}.tar.gz)
+sha1sums=('0556c392beb59433e577e3517575801212201df6')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package_hyphen() {
+ pkgdesc="library for high quality hyphenation and justification"
+ depends=('glibc' 'perl')
+
+ cd $pkgbase-$pkgver
+ make DESTDIR="$pkgdir/" install-libLTLIBRARIES
+ make DESTDIR="$pkgdir/" install-binSCRIPTS
+ make DESTDIR="$pkgdir/" install-includeHEADERS
+
+ # license
+ install -D -m644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
+
+package_hyphen-en() {
+ pkgdesc="English hyphenation rules"
+ # arch=('any')
+ optdepends=('hyphen: offers hyphenation library functions')
+
+ cd $pkgbase-$pkgver
+ make DESTDIR="$pkgdir/" install-hyphDATA
+
+ pushd ${pkgdir}/usr/share/hyphen/
+ en_US_aliases="en_AG en_AU en_BS en_BW en_BZ en_CA en_DK en_GB en_GH en_HK en_IE en_IN en_JM en_NA en_NZ en_PH en_SG en_TT en_ZA en_ZW"
+ for lang in $en_US_aliases; do
+ ln -s hyph_en_US.dic hyph_$lang.dic
+ done
+ popd
+
+ # the symlinks
+ install -dm755 ${pkgdir}/usr/share/myspell/dicts
+ pushd $pkgdir/usr/share/myspell/dicts
+ for file in $pkgdir/usr/share/hyphen/*; do
+ ln -sv /usr/share/hyphen/$(basename $file) .
+ done
+ popd
+}