summaryrefslogtreecommitdiffstats
path: root/abs/extra/icu
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-05 18:05:43 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-05 18:05:43 (GMT)
commit676db4cdf0ec3a29073ee4408b8a610b1b334bd3 (patch)
tree09c707617645155f0f9606e24ce7a2d7c2888098 /abs/extra/icu
parent0df8de97aa62100b27333c136cecfc2a1ea7ca21 (diff)
downloadlinhes_pkgbuild-676db4cdf0ec3a29073ee4408b8a610b1b334bd3.zip
linhes_pkgbuild-676db4cdf0ec3a29073ee4408b8a610b1b334bd3.tar.gz
linhes_pkgbuild-676db4cdf0ec3a29073ee4408b8a610b1b334bd3.tar.bz2
ice: initial inclusion. needed by openvmare-tools
Diffstat (limited to 'abs/extra/icu')
-rw-r--r--abs/extra/icu/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/extra/icu/PKGBUILD b/abs/extra/icu/PKGBUILD
new file mode 100644
index 0000000..14cd4aa
--- /dev/null
+++ b/abs/extra/icu/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 92974 2010-10-02 16:39:18Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Art Gramlich <art@gramlich-net.com>
+
+pkgname=icu
+pkgver=4.4.2
+pkgrel=1
+pkgdesc="International Components for Unicode library"
+arch=(i686 x86_64)
+url="http://www.icu-project.org/"
+license=('custom:"icu"')
+depends=('gcc-libs' 'sh')
+source=(http://download.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver//./_}-src.tgz
+ #http://download.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver/./_}-src.tgz
+)
+md5sums=('314e582264c36b3735466c522899aa07')
+
+
+build() {
+ cd ${srcdir}/icu/source
+ ./configure --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd ${srcdir}/icu/source
+ make -j1 DESTDIR=${pkgdir} install
+
+ # Install license
+ install -Dm644 ${srcdir}/icu/license.html ${pkgdir}/usr/share/licenses/icu/license.html
+}