summaryrefslogtreecommitdiffstats
path: root/abs/extra/iso-codes
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
commit5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (patch)
treef13051093a52f47f5954c2ee2a783bc2f0f62f96 /abs/extra/iso-codes
parent8d35f28049488f2585ef765bf48e7a58958fd587 (diff)
parent04697136037cb5341ee6c051f8aaa265c0400c82 (diff)
downloadlinhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.zip
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.gz
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/extra/iso-codes')
-rw-r--r--abs/extra/iso-codes/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/extra/iso-codes/PKGBUILD b/abs/extra/iso-codes/PKGBUILD
new file mode 100644
index 0000000..29b5211
--- /dev/null
+++ b/abs/extra/iso-codes/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=iso-codes
+pkgver=3.76
+pkgrel=1
+pkgdesc="Lists of the country, language, and currency names"
+arch=('any')
+url="https://pkg-isocodes.alioth.debian.org/"
+license=('LGPL')
+makedepends=('python' git)
+_commit=466dd437f40ec20d328dc5bf9ac57b64c4f954ab # tags/iso-codes-3.76
+source=("git+https://anonscm.debian.org/git/pkg-isocodes/iso-codes.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/^iso-codes-//;s/-/+/g'
+}
+
+prepare() {
+ cd $pkgname
+ autoreconf -fi
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" pkgconfigdir=/usr/lib/pkgconfig install
+}
+