summaryrefslogtreecommitdiffstats
path: root/abs/extra/jbig2dec
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-15 21:00:02 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-15 21:00:02 (GMT)
commitb820aee9cbca3afc64fc9108de718d898a61c713 (patch)
tree5a00359f9497d1f9742118ed7c668be77e4ed133 /abs/extra/jbig2dec
parent9be8cfb27c3db59bd8392d411162b6e5c20b9d03 (diff)
downloadlinhes_pkgbuild-b820aee9cbca3afc64fc9108de718d898a61c713.zip
linhes_pkgbuild-b820aee9cbca3afc64fc9108de718d898a61c713.tar.gz
linhes_pkgbuild-b820aee9cbca3afc64fc9108de718d898a61c713.tar.bz2
jbig2dec: dep of ghostscript
Diffstat (limited to 'abs/extra/jbig2dec')
-rw-r--r--abs/extra/jbig2dec/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/extra/jbig2dec/PKGBUILD b/abs/extra/jbig2dec/PKGBUILD
new file mode 100644
index 0000000..cc2bedd
--- /dev/null
+++ b/abs/extra/jbig2dec/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id$
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Bartłomiej Piotrowski
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=jbig2dec
+pkgver=0.14
+pkgrel=1
+pkgdesc='Decoder implementation of the JBIG2 image compression format'
+url='https://artifex.com/developers-ghostscript-jbig2dec/'
+arch=('x86_64')
+license=('GPL3')
+depends=('libpng')
+source=("https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs922/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('21b498c3ba566f283d02946f7e78e12abbad89f12fe4958974e50882c185014c')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}