summaryrefslogtreecommitdiffstats
path: root/abs/extra/jemalloc
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-09 21:03:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-09 21:03:27 (GMT)
commit050fb48e107e7f0aa78d3a0c0b6b937bd3b6c563 (patch)
tree9aa3d2bfd6a7d4e776d9a2e9d21cd827763af0d0 /abs/extra/jemalloc
parentdcf5edf4629a36d79eb80ef2d2fd98e8e4b42acc (diff)
downloadlinhes_pkgbuild-050fb48e107e7f0aa78d3a0c0b6b937bd3b6c563.zip
linhes_pkgbuild-050fb48e107e7f0aa78d3a0c0b6b937bd3b6c563.tar.gz
linhes_pkgbuild-050fb48e107e7f0aa78d3a0c0b6b937bd3b6c563.tar.bz2
jemalloc: initial inclusion. dep of mysql
Diffstat (limited to 'abs/extra/jemalloc')
-rw-r--r--abs/extra/jemalloc/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra/jemalloc/PKGBUILD b/abs/extra/jemalloc/PKGBUILD
new file mode 100644
index 0000000..5660be9
--- /dev/null
+++ b/abs/extra/jemalloc/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Kovivchak Evgen <oneonfire@gmail.com>
+
+pkgname=jemalloc
+pkgver=3.6.0
+pkgrel=1
+pkgdesc="General-purpose scalable concurrent malloc implementation"
+arch=('i686' 'x86_64')
+license=('BSD')
+url="http://www.canonware.com/jemalloc/"
+depends=('glibc')
+makedepends=('autoconf' 'make' 'bash')
+optdepends=(
+ 'perl: memory profiler'
+)
+source=(http://www.canonware.com/download/jemalloc/$pkgname-$pkgver.tar.bz2)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ CFLAGS="$CFLAGS -std=gnu11" ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ mv "$pkgdir"/usr/bin/{,jemalloc-}pprof
+ chmod 644 "$pkgdir"/usr/lib/*.a
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+sha256sums=('e16c2159dd3c81ca2dc3b5c9ef0d43e1f2f45b04548f42db12e7c12d7bdf84fe')