summaryrefslogtreecommitdiffstats
path: root/abs/extra/js52
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-27 13:34:54 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-27 13:34:54 (GMT)
commitef0a21c1b5b942595b706064f4122ed16fc4a0a9 (patch)
tree5b35ade3d85026d56455eb89ba35c815262f2fcf /abs/extra/js52
parent168df166590c264c05a7385776d80c30591a6ba6 (diff)
downloadlinhes_pkgbuild-ef0a21c1b5b942595b706064f4122ed16fc4a0a9.zip
linhes_pkgbuild-ef0a21c1b5b942595b706064f4122ed16fc4a0a9.tar.gz
linhes_pkgbuild-ef0a21c1b5b942595b706064f4122ed16fc4a0a9.tar.bz2
js52: dep of polkit
Diffstat (limited to 'abs/extra/js52')
-rw-r--r--abs/extra/js52/PKGBUILD75
-rw-r--r--abs/extra/js52/mozjs52-copy-headers.patch30
-rw-r--r--abs/extra/js52/mozjs52-disable-mozglue.patch66
-rw-r--r--abs/extra/js52/mozjs52-fix-soname.patch34
-rw-r--r--abs/extra/js52/mozjs52-include-configure-script.patch63
5 files changed, 268 insertions, 0 deletions
diff --git a/abs/extra/js52/PKGBUILD b/abs/extra/js52/PKGBUILD
new file mode 100644
index 0000000..6338a13
--- /dev/null
+++ b/abs/extra/js52/PKGBUILD
@@ -0,0 +1,75 @@
+# $Id$
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=js52
+pkgver=52.7.3
+pkgrel=1
+_ffver=${pkgver%%.*}
+pkgdesc="JavaScript interpreter and libraries - Version $_ffver"
+arch=(x86_64)
+url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
+license=(MPL)
+depends=(gcc-libs readline zlib sh)
+makedepends=(python2 zip autoconf2.13 mercurial)
+_repo=https://hg.mozilla.org/mozilla-unified
+source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}esr_RELEASE"
+ mozjs52-copy-headers.patch
+ mozjs52-disable-mozglue.patch
+ mozjs52-fix-soname.patch
+ mozjs52-include-configure-script.patch)
+sha256sums=('SKIP'
+ 'c5b3a88e4d10ef149aba6fc48d431db54ff266323fa22a5d549028fd794423cc'
+ '5a84f02521f37de873991dd360a4c4bfdbdd2fb4a218e11be73f9cbbf02050e8'
+ '06389b8e30465bb8e6fab6144dadedffa30595f143a686524da175b5cf5e8a27'
+ 'd91a89acd88bfc747a255050757a0c17139bf5c3508c2e1c3c6bb2056786a344')
+
+prepare() {
+ cd mozilla-unified
+
+ # https://anonscm.debian.org/git/pkg-gnome/mozjs52.git/tree/debian/patches
+ patch -Np1 -i ../mozjs52-fix-soname.patch
+ patch -Np1 -i ../mozjs52-copy-headers.patch
+ patch -Np1 -i ../mozjs52-disable-mozglue.patch
+ patch -Np1 -i ../mozjs52-include-configure-script.patch
+}
+
+build() {
+ unset CPPFLAGS
+ CFLAGS+=' -fno-delete-null-pointer-checks -fno-strict-aliasing -fno-tree-vrp -flto=3'
+ CXXFLAGS+=' -fno-delete-null-pointer-checks -fno-strict-aliasing -fno-tree-vrp -flto=3'
+ export CC=gcc CXX=g++ PYTHON=/usr/bin/python2 SHELL=/bin/bash
+
+ cd mozilla-unified/js/src
+ sh configure \
+ --prefix=/usr \
+ --disable-debug \
+ --disable-debug-symbols \
+ --disable-strip \
+ --enable-gold \
+ --enable-optimize="-O2" \
+ --enable-pie \
+ --enable-posix-nspr-emulation \
+ --enable-readline \
+ --enable-release \
+ --enable-shared-js \
+ --enable-tests \
+ --with-intl-api \
+ --with-system-zlib \
+ --without-system-icu
+ make
+}
+
+check() {
+ cd mozilla-unified/js/src
+ python2 tests/jstests.py -d -s -t 300 --no-progress ../../js/src/js/src/shell/js
+ python2 jit-test/jit_test.py -s -t 300 --no-progress ../../js/src/js/src/shell/js basic
+}
+
+package() {
+ cd mozilla-unified/js/src
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/lib/*.ajs
+ find "$pkgdir"/usr/{lib/pkgconfig,include} -type f -exec chmod -c a-x {} +
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/js52/mozjs52-copy-headers.patch b/abs/extra/js52/mozjs52-copy-headers.patch
new file mode 100644
index 0000000..69b2161
--- /dev/null
+++ b/abs/extra/js52/mozjs52-copy-headers.patch
@@ -0,0 +1,30 @@
+From 8b2d7a77bfb4dbd513763501ed7e9722058ee9af Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Wed, 5 Jul 2017 22:45:59 -0700
+Subject: [PATCH] build: Copy headers on install instead of symlinking
+
+Patch ported forward to mozjs52 by Philip Chimento
+<philip.chimento@gmail.com>.
+---
+ python/mozbuild/mozbuild/backend/recursivemake.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/python/mozbuild/mozbuild/backend/recursivemake.py b/python/mozbuild/mozbuild/backend/recursivemake.py
+index 132dcf94..33d489a6 100644
+--- a/python/mozbuild/mozbuild/backend/recursivemake.py
++++ b/python/mozbuild/mozbuild/backend/recursivemake.py
+@@ -1307,11 +1307,11 @@ def _process_final_target_files(self, obj, files, backend_file):
+ raise Exception("Wildcards are only supported in the filename part of "
+ "srcdir-relative or absolute paths.")
+
+- install_manifest.add_pattern_symlink(basepath, wild, path)
++ install_manifest.add_pattern_copy(basepath, wild, path)
+ else:
+- install_manifest.add_pattern_symlink(f.srcdir, f, path)
++ install_manifest.add_pattern_copy(f.srcdir, f, path)
+ else:
+- install_manifest.add_symlink(f.full_path, dest)
++ install_manifest.add_copy(f.full_path, dest)
+ else:
+ install_manifest.add_optional_exists(dest)
+ backend_file.write('%s_FILES += %s\n' % (
diff --git a/abs/extra/js52/mozjs52-disable-mozglue.patch b/abs/extra/js52/mozjs52-disable-mozglue.patch
new file mode 100644
index 0000000..8355cf4
--- /dev/null
+++ b/abs/extra/js52/mozjs52-disable-mozglue.patch
@@ -0,0 +1,66 @@
+From 7e6d628456af3e99ebcb9a01a27e1461585082a4 Mon Sep 17 00:00:00 2001
+From: Till Schneidereit <till@tillschneidereit.net>
+Date: Thu, 1 Oct 2015 12:59:09 +0200
+Subject: [PATCH] Disable MOZ_GLUE_IN_PROGRAM in stand-alone builds on all
+ platforms
+
+Otherwise, build fails not being able to find HashBytes.
+
+Patch ported forward to mozjs52 by Philip Chimento
+<philip.chimento@gmail.com>.
+
+https://bugzilla.mozilla.org/show_bug.cgi?id=1176787
+---
+ js/src/old-configure.in | 23 ++++++++++++++---------
+ mozglue/build/moz.build | 2 +-
+ 2 files changed, 15 insertions(+), 10 deletions(-)
+
+diff --git a/js/src/old-configure.in b/js/src/old-configure.in
+index 1c5c9e21..ff0617e3 100644
+--- a/js/src/old-configure.in
++++ b/js/src/old-configure.in
+@@ -1623,16 +1623,21 @@ dnl ========================================================
+ dnl = Enable jemalloc
+ dnl ========================================================
+
+-case "${OS_TARGET}" in
+-Android|WINNT|Darwin)
++dnl In stand-alone builds we always only want to link executables against mozglue.
++if test "$JS_STANDALONE"; then
+ MOZ_GLUE_IN_PROGRAM=
+- ;;
+-*)
+- dnl On !Android !Windows !OSX, we only want to link executables against mozglue
+- MOZ_GLUE_IN_PROGRAM=1
+- AC_DEFINE(MOZ_GLUE_IN_PROGRAM)
+- ;;
+-esac
++else
++ case "${OS_TARGET}" in
++ Android|WINNT|Darwin)
++ MOZ_GLUE_IN_PROGRAM=
++ ;;
++ *)
++ dnl On !Android !Windows !OSX, we only want to link executables against mozglue
++ MOZ_GLUE_IN_PROGRAM=1
++ AC_DEFINE(MOZ_GLUE_IN_PROGRAM)
++ ;;
++ esac
++fi
+
+ if test "$MOZ_MEMORY"; then
+ if test "x$MOZ_DEBUG" = "x1"; then
+diff --git a/mozglue/build/moz.build b/mozglue/build/moz.build
+index d2897477..e3be5a2b 100644
+--- a/mozglue/build/moz.build
++++ b/mozglue/build/moz.build
+@@ -6,7 +6,7 @@
+
+ # Build mozglue as a shared lib on Windows, OSX and Android.
+ # If this is ever changed, update MOZ_SHARED_MOZGLUE in browser/installer/Makefile.in
+-if CONFIG['OS_TARGET'] in ('WINNT', 'Darwin', 'Android'):
++if CONFIG['OS_TARGET'] in ('WINNT', 'Darwin', 'Android') and not CONFIG['JS_STANDALONE']:
+ SharedLibrary('mozglue')
+ else:
+ Library('mozglue')
+
diff --git a/abs/extra/js52/mozjs52-fix-soname.patch b/abs/extra/js52/mozjs52-fix-soname.patch
new file mode 100644
index 0000000..a91107c
--- /dev/null
+++ b/abs/extra/js52/mozjs52-fix-soname.patch
@@ -0,0 +1,34 @@
+From: Laszlo Boszormenyi (GCS) <gcs@debian.org>
+Date: Fri, 02 May 2014 22:20:45 +0200
+Subject: fix soname
+
+Add soname switch to linker, regardless of Operating System
+
+Bug-Debian: http://bugs.debian.org/746705
+---
+ config/rules.mk | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+Index: mozjs52-52.2.1~artful1/config/rules.mk
+===================================================================
+--- mozjs52-52.2.1~artful1.orig/config/rules.mk
++++ mozjs52-52.2.1~artful1/config/rules.mk
+@@ -418,7 +418,7 @@ endif # AIX
+ #
+ # Linux: add -Bsymbolic flag for components
+ #
+-ifeq ($(OS_ARCH),Linux)
++#ifeq ($(OS_ARCH),Linux)
+ ifdef IS_COMPONENT
+ EXTRA_DSO_LDOPTS += -Wl,-Bsymbolic
+ endif
+@@ -426,7 +426,8 @@ ifdef LD_VERSION_SCRIPT
+ EXTRA_DSO_LDOPTS += -Wl,--version-script,$(LD_VERSION_SCRIPT)
+ EXTRA_DEPS += $(LD_VERSION_SCRIPT)
+ endif
+-endif
++#endif
++EXTRA_DSO_LDOPTS += -Wl,-soname,lib$(JS_LIBRARY_NAME).so.0
+
+ ifdef SYMBOLS_FILE
+ ifeq ($(OS_TARGET),WINNT)
diff --git a/abs/extra/js52/mozjs52-include-configure-script.patch b/abs/extra/js52/mozjs52-include-configure-script.patch
new file mode 100644
index 0000000..523e657
--- /dev/null
+++ b/abs/extra/js52/mozjs52-include-configure-script.patch
@@ -0,0 +1,63 @@
+From 4a06a1a6a71293decb83aee7adb74bc709493106 Mon Sep 17 00:00:00 2001
+From: Philip Chimento <philip.chimento@gmail.com>
+Date: Wed, 5 Jul 2017 22:57:09 -0700
+Subject: [PATCH] build: Include configure script, be nicer about options
+
+A configure script is not included in the SpiderMonkey tarball by
+default. Also, we have to account for JHbuild passing extra unknown
+options like --disable-Werror.
+
+https://bugzilla.mozilla.org/show_bug.cgi?id=1379540
+---
+ js/src/configure | 9 +++++++++
+ python/mozbuild/mozbuild/configure/__init__.py | 2 +-
+ python/mozbuild/mozbuild/configure/options.py | 6 +++++-
+ 3 files changed, 15 insertions(+), 2 deletions(-)
+ create mode 100755 js/src/configure
+
+diff --git a/js/src/configure b/js/src/configure
+new file mode 100755
+index 00000000..f1ef8c49
+--- /dev/null
++++ b/js/src/configure
+@@ -0,0 +1,9 @@
++#!/bin/sh
++
++SRCDIR=$(dirname $0)
++TOPSRCDIR="$SRCDIR"/../..
++export OLD_CONFIGURE="$SRCDIR"/old-configure
++
++set -- "$@" --enable-project=js
++
++which python2.7 > /dev/null && exec python2.7 "$TOPSRCDIR/configure.py" "$@" || exec python "$TOPSRCDIR/configure.py" "$@"
+diff --git a/python/mozbuild/mozbuild/configure/__init__.py b/python/mozbuild/mozbuild/configure/__init__.py
+index 0fe640ca..09b460d3 100644
+--- a/python/mozbuild/mozbuild/configure/__init__.py
++++ b/python/mozbuild/mozbuild/configure/__init__.py
+@@ -356,7 +356,7 @@ def run(self, path=None):
+ # All options should have been removed (handled) by now.
+ for arg in self._helper:
+ without_value = arg.split('=', 1)[0]
+- raise InvalidOptionError('Unknown option: %s' % without_value)
++ print('Ignoring', without_value, ': Unknown option')
+
+ # Run the execution queue
+ for func, args in self._execution_queue:
+diff --git a/python/mozbuild/mozbuild/configure/options.py b/python/mozbuild/mozbuild/configure/options.py
+index 4310c862..15bfe425 100644
+--- a/python/mozbuild/mozbuild/configure/options.py
++++ b/python/mozbuild/mozbuild/configure/options.py
+@@ -402,7 +402,11 @@ def __init__(self, environ=os.environ, argv=sys.argv):
+
+ def add(self, arg, origin='command-line', args=None):
+ assert origin != 'default'
+- prefix, name, values = Option.split_option(arg)
++ try:
++ prefix, name, values = Option.split_option(arg)
++ except InvalidOptionError as e:
++ print('Ignoring', arg, ':', e)
++ return
+ if args is None:
+ args = self._extra_args
+ if args is self._extra_args and name in self._extra_args:
+