summaryrefslogtreecommitdiffstats
path: root/abs/extra/json-c
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-05 00:09:00 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-05 00:09:00 (GMT)
commitf452e1f7cc7437640fd1ff64cf5cdc17a5101786 (patch)
tree8646ff0bcada4954116988fdaf3de0015f354973 /abs/extra/json-c
parent14a843531e558e77982ebb8efdeb887e8ef052b2 (diff)
downloadlinhes_pkgbuild-f452e1f7cc7437640fd1ff64cf5cdc17a5101786.zip
linhes_pkgbuild-f452e1f7cc7437640fd1ff64cf5cdc17a5101786.tar.gz
linhes_pkgbuild-f452e1f7cc7437640fd1ff64cf5cdc17a5101786.tar.bz2
json-c: update to 0.13
Diffstat (limited to 'abs/extra/json-c')
-rw-r--r--abs/extra/json-c/PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/abs/extra/json-c/PKGBUILD b/abs/extra/json-c/PKGBUILD
index 70dd735..d4795e3 100644
--- a/abs/extra/json-c/PKGBUILD
+++ b/abs/extra/json-c/PKGBUILD
@@ -4,30 +4,30 @@
# Contributor: congyiwu <congyiwu AT gmail DOT com>
pkgname=json-c
-pkgver=0.12
-pkgrel=2
-pkgdesc="A JSON implementation in C"
-url="https://github.com/json-c/json-c/wiki"
+pkgver=0.13
+pkgrel=1
+pkgdesc='A JSON implementation in C'
+url='https://github.com/json-c/json-c/wiki'
license=(MIT)
-arch=(i686 x86_64)
-depends=(glibc)
-source=(https://s3.amazonaws.com/${pkgname}_releases/releases/$pkgname-${pkgver}.tar.gz)
-sha256sums=('000c01b2b3f82dcb4261751eb71f1b084404fb7d6a282f06074d3c17078b9f3f')
+arch=('x86_64')
+depends=('glibc')
+source=('https://github.com/json-c/json-c/archive/json-c-0.13-20171207.tar.gz')
+sha256sums=('26e642456caab38aa9459279b9712ffec52f751e9f46641d28461c244bd6bae6')
build() {
- cd $pkgname-$pkgver
+ cd $pkgname-$pkgname-$pkgver-20171207
CFLAGS="$CFLAGS -Wno-error"
./configure --prefix=/usr --disable-static
make
}
check() {
- cd $pkgname-$pkgver
+ cd $pkgname-$pkgname-$pkgver-20171207
make check
}
package() {
- cd $pkgname-$pkgver
+ cd $pkgname-$pkgname-$pkgver-20171207
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}