summaryrefslogtreecommitdiffstats
path: root/abs/extra/json-glib
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-01 18:22:56 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-01 18:22:56 (GMT)
commit7ce2899517edce1af92156100cb6e49f28b34eab (patch)
treed22fafc46dec710cdf8244555dae5dc139ed2423 /abs/extra/json-glib
parent8ed20fc8962962527ca2b6c0bc98dd220a0dd198 (diff)
downloadlinhes_pkgbuild-7ce2899517edce1af92156100cb6e49f28b34eab.zip
linhes_pkgbuild-7ce2899517edce1af92156100cb6e49f28b34eab.tar.gz
linhes_pkgbuild-7ce2899517edce1af92156100cb6e49f28b34eab.tar.bz2
json-glib: inital inclusion. dep of gtk3
Diffstat (limited to 'abs/extra/json-glib')
-rw-r--r--abs/extra/json-glib/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/extra/json-glib/PKGBUILD b/abs/extra/json-glib/PKGBUILD
new file mode 100644
index 0000000..9ad0257
--- /dev/null
+++ b/abs/extra/json-glib/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id$
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=json-glib
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="JSON library built on GLib"
+arch=('i686' 'x86_64')
+url="http://live.gnome.org/JsonGlib"
+license=('GPL')
+depends=('glib2')
+makedepends=('gobject-introspection')
+source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver:0:3}/${pkgname}-${pkgver}.tar.xz)
+sha256sums=('887bd192da8f5edc53b490ec51bf3ffebd958a671f5963e4f3af32c22e35660a')
+
+build(){
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package(){
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+
+check(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make check
+}