summaryrefslogtreecommitdiffstats
path: root/abs/extra/kodi
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-08-08 21:36:43 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-08-08 21:36:43 (GMT)
commit468dfe604fbae3ccb5367bb011f864df2a9c7bab (patch)
treee1ac58c23f59e6ac748af9855a3a2cdb35aca521 /abs/extra/kodi
parentea1aafd3af42ac0c5b573212b9b24ab7d9b4d397 (diff)
downloadlinhes_pkgbuild-468dfe604fbae3ccb5367bb011f864df2a9c7bab.zip
linhes_pkgbuild-468dfe604fbae3ccb5367bb011f864df2a9c7bab.tar.gz
linhes_pkgbuild-468dfe604fbae3ccb5367bb011f864df2a9c7bab.tar.bz2
kodi: update to 15.0
Diffstat (limited to 'abs/extra/kodi')
-rw-r--r--abs/extra/kodi/PKGBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/abs/extra/kodi/PKGBUILD b/abs/extra/kodi/PKGBUILD
index 134d325..09b14f2 100644
--- a/abs/extra/kodi/PKGBUILD
+++ b/abs/extra/kodi/PKGBUILD
@@ -13,9 +13,9 @@ _prefix=/usr
pkgbase=kodi
pkgname=('kodi' 'kodi-eventclients')
-pkgver=14.2
-_codename=Helix
-pkgrel=3
+pkgver=15.0
+_codename=Isengard
+pkgrel=1
arch=('i686' 'x86_64')
url="http://kodi.tv"
license=('GPL2')
@@ -24,9 +24,10 @@ makedepends=(
'gperf' 'hicolor-icon-theme' 'jasper' 'java-runtime' 'libaacs' 'libass'
'libbluray' 'libcdio' 'libcec' 'libgl' 'libmariadbclient' 'libmicrohttpd'
'libmodplug' 'libmpeg2' 'libnfs' 'libplist' 'libssh' 'libva'
- 'libvdpau' 'libxrandr' 'libxslt' 'lzo' 'nasm' 'nss-mdns' 'python2-pillow'
- 'python2-pybluez' 'python2-simplejson' 'rtmpdump' 'sdl2' 'sdl_image'
- 'shairplay' 'smbclient' 'swig' 'taglib' 'tinyxml' 'unzip' 'upower' 'yajl' 'zip'
+ 'libvdpau' 'libxrandr' 'libxslt' 'lzo' 'mesa' 'nasm' 'nss-mdns'
+ 'python2-pillow' 'python2-pybluez' 'python2-simplejson' 'rtmpdump' 'sdl2'
+ 'sdl_image' 'shairplay' 'smbclient' 'swig' 'taglib' 'tinyxml' 'unzip' 'upower'
+ 'yajl' 'zip'
)
source=(
"$pkgname-$pkgver-$_codename.tar.gz::https://github.com/xbmc/xbmc/archive/$pkgver-$_codename.tar.gz"
@@ -41,10 +42,6 @@ prepare() {
sed 's|^#!.*python$|#!/usr/bin/python2|' -i tools/depends/native/rpl-native/rpl
sed 's/python/python2/' -i tools/Linux/kodi.sh.in
sed 's/shell python/shell python2/' -i tools/EventClients/Makefile.in
- # disable wiiremote due to incompatibility with bluez-5.29
- sed '/WiiRemote/d' -i tools/EventClients/Makefile.in
- sed '/mkdir -p $(DESTDIR)$(bindir)/i \
-install:' -i tools/EventClients/Makefile.in
}
build() {
@@ -62,9 +59,9 @@ build() {
--disable-debug \
--enable-optimizations \
--enable-libbluray \
- --enable-external-libraries \
+ --enable-shared-libraries \
--with-lirc-device=/run/lirc/lircd \
- ac_cv_lib_bluetooth_hci_devid=no
+ ac_cv_type__Bool=yes
# Now (finally) build
make
@@ -137,6 +134,6 @@ package_kodi-eventclients() {
make DESTDIR="$pkgdir" eventclients WII_EXTRA_OPTS=-DCWIID_OLD
}
-md5sums=('aa534c483cdd6cda71e5350c2094175b'
+md5sums=('d3bd3dc9fd705bcf59d8c91199994537'
'f6adc8e06d7076143ca2ad118126b158'
'f04d1c89f5108c6aba36cf708a74cc95')