summaryrefslogtreecommitdiffstats
path: root/abs/extra/libaio/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-02-19 18:16:16 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-02-19 18:16:16 (GMT)
commit8de064f6e96f960cdbfe6868d9957a4613f704df (patch)
tree4e73a420991733450d013529c0fee60e0365297a /abs/extra/libaio/PKGBUILD
parent0374b16f1e15ba1819b62bd5a6e0076ac7b243d0 (diff)
parent6fde8cd5e74f0840e01988e743464fe91c0a28f8 (diff)
downloadlinhes_pkgbuild-8de064f6e96f960cdbfe6868d9957a4613f704df.zip
linhes_pkgbuild-8de064f6e96f960cdbfe6868d9957a4613f704df.tar.gz
linhes_pkgbuild-8de064f6e96f960cdbfe6868d9957a4613f704df.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/extra/libaio/PKGBUILD')
-rw-r--r--abs/extra/libaio/PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/abs/extra/libaio/PKGBUILD b/abs/extra/libaio/PKGBUILD
index 41ca5d6..08d74db 100644
--- a/abs/extra/libaio/PKGBUILD
+++ b/abs/extra/libaio/PKGBUILD
@@ -3,20 +3,28 @@
# Contributor: Thomas S Hatch <thatch45 at gmail dot com>
pkgname=libaio
-pkgver=0.3.109
-pkgrel=7
+pkgver=0.3.110
+pkgrel=1
pkgdesc="The Linux-native asynchronous I/O facility (aio) library"
arch=('i686' 'x86_64')
url="http://lse.sourceforge.net/io/aio.html"
license=('LGPL')
source=(http://ftp.de.debian.org/debian/pool/main/liba/$pkgname/${pkgname}_${pkgver}.orig.tar.gz)
-md5sums=('435a5b16ca6198eaf01155263d855756')
+md5sums=('2a35602e43778383e2f4907a4ca39ab8')
build() {
cd "$srcdir/$pkgname-$pkgver"
+ # AIO library is a thin wrapper around kernel syscalls, it does not use stdlib
+ # and other helpers like stack protection libraries
+ CFLAGS="-march=${CARCH/_/-} -mtune=generic -O2 -pipe"
make
}
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make partcheck
+}
+
package() {
cd "$srcdir/$pkgname-$pkgver"
make prefix="$pkgdir/usr" install