summaryrefslogtreecommitdiffstats
path: root/abs/extra/libaio
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-09 20:58:18 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-09 20:58:18 (GMT)
commitdcf5edf4629a36d79eb80ef2d2fd98e8e4b42acc (patch)
treeb78616d3463a6c956b1b0177142b4480ae18f4e7 /abs/extra/libaio
parenta9a64aacfa3baa66818d631e3fa125f64507c040 (diff)
downloadlinhes_pkgbuild-dcf5edf4629a36d79eb80ef2d2fd98e8e4b42acc.zip
linhes_pkgbuild-dcf5edf4629a36d79eb80ef2d2fd98e8e4b42acc.tar.gz
linhes_pkgbuild-dcf5edf4629a36d79eb80ef2d2fd98e8e4b42acc.tar.bz2
libaio: 0.3.110
Diffstat (limited to 'abs/extra/libaio')
-rw-r--r--abs/extra/libaio/PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/abs/extra/libaio/PKGBUILD b/abs/extra/libaio/PKGBUILD
index 41ca5d6..08d74db 100644
--- a/abs/extra/libaio/PKGBUILD
+++ b/abs/extra/libaio/PKGBUILD
@@ -3,20 +3,28 @@
# Contributor: Thomas S Hatch <thatch45 at gmail dot com>
pkgname=libaio
-pkgver=0.3.109
-pkgrel=7
+pkgver=0.3.110
+pkgrel=1
pkgdesc="The Linux-native asynchronous I/O facility (aio) library"
arch=('i686' 'x86_64')
url="http://lse.sourceforge.net/io/aio.html"
license=('LGPL')
source=(http://ftp.de.debian.org/debian/pool/main/liba/$pkgname/${pkgname}_${pkgver}.orig.tar.gz)
-md5sums=('435a5b16ca6198eaf01155263d855756')
+md5sums=('2a35602e43778383e2f4907a4ca39ab8')
build() {
cd "$srcdir/$pkgname-$pkgver"
+ # AIO library is a thin wrapper around kernel syscalls, it does not use stdlib
+ # and other helpers like stack protection libraries
+ CFLAGS="-march=${CARCH/_/-} -mtune=generic -O2 -pipe"
make
}
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make partcheck
+}
+
package() {
cd "$srcdir/$pkgname-$pkgver"
make prefix="$pkgdir/usr" install