summaryrefslogtreecommitdiffstats
path: root/abs/extra/libclc
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-15 18:12:38 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-15 18:12:38 (GMT)
commit1db4af5b60efdcd8be008e0e7f01b7bbbccf4980 (patch)
tree0ad61be6d0684c63656eb0840dbb614e155bb978 /abs/extra/libclc
parent0893740c8ac18ce661272ba890aa74ad78fdaeb9 (diff)
downloadlinhes_pkgbuild-1db4af5b60efdcd8be008e0e7f01b7bbbccf4980.zip
linhes_pkgbuild-1db4af5b60efdcd8be008e0e7f01b7bbbccf4980.tar.gz
linhes_pkgbuild-1db4af5b60efdcd8be008e0e7f01b7bbbccf4980.tar.bz2
libclc: initial inclusion. dep of mesa
Diffstat (limited to 'abs/extra/libclc')
-rw-r--r--abs/extra/libclc/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/extra/libclc/PKGBUILD b/abs/extra/libclc/PKGBUILD
new file mode 100644
index 0000000..2a7b414
--- /dev/null
+++ b/abs/extra/libclc/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id$
+# Maintainer: Laurent Carlier <lordheavym@gmail.com>
+
+pkgname=libclc
+pkgver=0.0.1.217247
+pkgrel=1
+pkgdesc="Library requirements of the OpenCL C programming language"
+arch=('any')
+url="http://libclc.llvm.org/"
+license=('MIT')
+makedepends=('clang' 'svn' 'python2')
+options=('staticlibs')
+source=('libclc::svn+http://llvm.org/svn/llvm-project/libclc/trunk#revision=217247')
+md5sums=(SKIP)
+
+build() {
+ cd libclc
+
+ sed -i 's/"python < $in >/sys.executable + " < $in >/g' configure.py
+# sed -i 's/python < $in >/python2 < $in >/g' configure.py
+
+ python2 ./configure.py --prefix=/usr
+ make
+}
+
+package() {
+ cd libclc
+
+ make install DESTDIR="$pkgdir"
+ install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+