summaryrefslogtreecommitdiffstats
path: root/abs/extra/libcrystalhd-git
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-06 03:44:26 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-06 03:44:26 (GMT)
commit5a04c12e361286dfb06158729ef40f47b71e1b53 (patch)
treeb2e9c72761238201711d418f22d49b31068a3bcc /abs/extra/libcrystalhd-git
parent4eca038debb1857f60b5a096f5484bb46bacfffe (diff)
downloadlinhes_pkgbuild-5a04c12e361286dfb06158729ef40f47b71e1b53.zip
linhes_pkgbuild-5a04c12e361286dfb06158729ef40f47b71e1b53.tar.gz
linhes_pkgbuild-5a04c12e361286dfb06158729ef40f47b71e1b53.tar.bz2
libcrystalhd-git: initial include
Diffstat (limited to 'abs/extra/libcrystalhd-git')
-rw-r--r--abs/extra/libcrystalhd-git/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/abs/extra/libcrystalhd-git/PKGBUILD b/abs/extra/libcrystalhd-git/PKGBUILD
new file mode 100644
index 0000000..27d8fff
--- /dev/null
+++ b/abs/extra/libcrystalhd-git/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Petteri Tolonen <petteri.tolonen@gmail.com>
+pkgname=libcrystalhd-git
+pkgver=`date +%Y%m%d`
+pkgrel=1
+pkgdesc="Broadcom Crystal HD library from git.wilsonet.com"
+arch=('i686' 'x86_64')
+url="http://git.wilsonet.com/crystalhd.git/"
+license=('GPL2')
+depends=('gcc-libs')
+makedepends=('git' 'make')
+conflicts=('libcrystalhd')
+
+_gitroot='git://git.wilsonet.com/crystalhd.git'
+_gitname='crystalhd'
+
+build() {
+
+ cd $startdir/src
+
+ msg "Connecting to git.wilsonet.com GIT server...."
+
+ if [ -d $startdir/src/$_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ cd $_gitname
+ fi
+
+ cd linux_lib/libcrystalhd
+
+ make || return 1
+ make install DESTDIR=$pkgdir || return 1
+
+}