summaryrefslogtreecommitdiffstats
path: root/abs/extra/libdvdcss
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:54:38 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:54:38 (GMT)
commit961ae5e98558069e1fc9d7c404197ee391b8ba35 (patch)
treed069719b2b922776d6edd30a4b482b59768aa149 /abs/extra/libdvdcss
parent3272617ead5fc5dd0ccc1486255ea45162ee0ebd (diff)
downloadlinhes_pkgbuild-961ae5e98558069e1fc9d7c404197ee391b8ba35.zip
linhes_pkgbuild-961ae5e98558069e1fc9d7c404197ee391b8ba35.tar.gz
linhes_pkgbuild-961ae5e98558069e1fc9d7c404197ee391b8ba35.tar.bz2
libdvdcss 1.2.12
Diffstat (limited to 'abs/extra/libdvdcss')
-rw-r--r--abs/extra/libdvdcss/PKGBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/abs/extra/libdvdcss/PKGBUILD b/abs/extra/libdvdcss/PKGBUILD
index 80772fa..c6b1807 100644
--- a/abs/extra/libdvdcss/PKGBUILD
+++ b/abs/extra/libdvdcss/PKGBUILD
@@ -1,24 +1,27 @@
-# $Id: PKGBUILD 37036 2009-04-30 04:50:40Z eric $
-# Maintainer: arjan <arjan@archlinux.org>
+# $Id: PKGBUILD 160018 2012-05-28 02:15:20Z eric $
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: arjan <arjan@archlinux.org>
# Contributor Sarah Hay <sarahhay@mb.sympatico.ca>
pkgname=libdvdcss
-pkgver=1.2.10
-pkgrel=1.1
-pkgdesc="libdvdcss is a cross-platform library for transparent DVD device access with on-the-fly CSS decryption."
+pkgver=1.2.12
+pkgrel=1
+pkgdesc="A portable abstraction library for DVD decryption"
+url="http://www.videolan.org/libdvdcss"
arch=('i686' 'x86_64')
license=('GPL')
depends=('glibc')
options=('!libtool')
-source=(http://download.videolan.org/pub/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2)
-md5sums=('ebd5370b79ac5a83e5c61b24a214cf74')
-url="http://www.videolan.org/libdvdcss/"
-
+source=(http://download.videolan.org/pub/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('2218a193900e3203aa10dc24cdf54275')
build() {
- cd $srcdir/$pkgname-$pkgver
- ./configure --prefix=/usr || return 1
- make || return 1
- make DESTDIR=$pkgdir install || return 1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}