summaryrefslogtreecommitdiffstats
path: root/abs/extra/libepoxy
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-06-21 19:50:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-06-21 19:50:12 (GMT)
commit4fdceb659fb1756f9029a2ff1f07c0b8f701c045 (patch)
tree640db290b40bf916be949464080ae2a46fb3bdc4 /abs/extra/libepoxy
parentfe0f5b8a782211a521c843fe728d7fddb854efe9 (diff)
downloadlinhes_pkgbuild-4fdceb659fb1756f9029a2ff1f07c0b8f701c045.zip
linhes_pkgbuild-4fdceb659fb1756f9029a2ff1f07c0b8f701c045.tar.gz
linhes_pkgbuild-4fdceb659fb1756f9029a2ff1f07c0b8f701c045.tar.bz2
libepoxy: initial inclusion. dep of xorg-server
Diffstat (limited to 'abs/extra/libepoxy')
-rw-r--r--abs/extra/libepoxy/PKGBUILD35
-rw-r--r--abs/extra/libepoxy/__changelog1
2 files changed, 36 insertions, 0 deletions
diff --git a/abs/extra/libepoxy/PKGBUILD b/abs/extra/libepoxy/PKGBUILD
new file mode 100644
index 0000000..5ba5cf8
--- /dev/null
+++ b/abs/extra/libepoxy/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id$
+# Maintainer: Laurent Carlier <lordheavym@gmail.com>
+
+pkgname=libepoxy
+pkgver=1.2
+pkgrel=2
+pkgdesc="A library for handling OpenGL function pointer management for you"
+url="https://github.com/anholt/libepoxy"
+arch=('i686' 'x86_64')
+license=(MIT)
+depends=('glibc')
+makedepends=('xorg-util-macros' 'python2' 'mesa-libgl')
+options=('!libtool')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/anholt/${pkgname}/archive/v${pkgver}.tar.gz)
+md5sums=('12d6b7621f086c0c928887c27d90bc30')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ ./autogen.sh --prefix=/usr
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+
+ make -k check
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
+}
+
diff --git a/abs/extra/libepoxy/__changelog b/abs/extra/libepoxy/__changelog
new file mode 100644
index 0000000..00bdcfb
--- /dev/null
+++ b/abs/extra/libepoxy/__changelog
@@ -0,0 +1 @@
+-PKGBUILD: change dep python to python2