summaryrefslogtreecommitdiffstats
path: root/abs/extra/libepoxy
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2019-01-31 19:29:36 (GMT)
committerBritney Fransen <brfransen@gmail.com>2019-01-31 19:29:36 (GMT)
commit9248a53e832bf0d5278a2cd5239a72287781b181 (patch)
treecf2ecdf0e2dc792ba599b5bd2f91dea609a02a5c /abs/extra/libepoxy
parentf7fa776785647c797bd1e29498a52c565be69de5 (diff)
downloadlinhes_pkgbuild-9248a53e832bf0d5278a2cd5239a72287781b181.zip
linhes_pkgbuild-9248a53e832bf0d5278a2cd5239a72287781b181.tar.gz
linhes_pkgbuild-9248a53e832bf0d5278a2cd5239a72287781b181.tar.bz2
libepoxy: update to 1.5.3
Diffstat (limited to 'abs/extra/libepoxy')
-rw-r--r--abs/extra/libepoxy/PKGBUILD48
1 files changed, 28 insertions, 20 deletions
diff --git a/abs/extra/libepoxy/PKGBUILD b/abs/extra/libepoxy/PKGBUILD
index 5ba5cf8..213ccfe 100644
--- a/abs/extra/libepoxy/PKGBUILD
+++ b/abs/extra/libepoxy/PKGBUILD
@@ -1,35 +1,43 @@
-# $Id$
# Maintainer: Laurent Carlier <lordheavym@gmail.com>
pkgname=libepoxy
-pkgver=1.2
-pkgrel=2
-pkgdesc="A library for handling OpenGL function pointer management for you"
+pkgver=1.5.3
+pkgrel=1
+pkgdesc="Library handling OpenGL function pointer management"
url="https://github.com/anholt/libepoxy"
-arch=('i686' 'x86_64')
+arch=(x86_64)
license=(MIT)
-depends=('glibc')
-makedepends=('xorg-util-macros' 'python2' 'mesa-libgl')
-options=('!libtool')
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/anholt/${pkgname}/archive/v${pkgver}.tar.gz)
-md5sums=('12d6b7621f086c0c928887c27d90bc30')
+depends=(glibc)
+makedepends=(python mesa-libgl git meson doxygen graphviz)
+_commit=16b1481e00084682d5ae5d38178e3e418976dfae # tags/1.5.3^0
+source=("git+https://github.com/anholt/libepoxy#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
-build() {
- cd "${pkgname}-${pkgver}"
+prepare() {
+ cd $pkgname
+ # Reduce docs size
+ printf '%s\n' >>doc/Doxyfile.in \
+ HAVE_DOT=yes DOT_IMAGE_FORMAT=svg INTERACTIVE_SVG=yes
+}
- ./autogen.sh --prefix=/usr
+build() {
+ arch-meson $pkgname build \
+ -D docs=true
+ ninja -C build
}
check() {
- cd "${pkgname}-${pkgver}"
-
- make -k check
+ meson test -C build
}
package() {
- cd "${pkgname}-${pkgver}"
-
- make DESTDIR="$pkgdir" install
- install -Dm644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
+ DESTDIR="$pkgdir" meson install -C build
+ install -Dm644 $pkgname/COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+# vim:set sw=2 et: