summaryrefslogtreecommitdiffstats
path: root/abs/extra/libfastjson
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-02-07 22:25:08 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-02-07 22:25:08 (GMT)
commit40c97d4ccad2d9c7dc6df0ea12ddb3c5b6a7b66f (patch)
treee25fd4de243f0f2e28bb42100df206b59ca18413 /abs/extra/libfastjson
parent39eaadf76d1ea3f7fa86b7060526552ad09843a6 (diff)
downloadlinhes_pkgbuild-40c97d4ccad2d9c7dc6df0ea12ddb3c5b6a7b66f.zip
linhes_pkgbuild-40c97d4ccad2d9c7dc6df0ea12ddb3c5b6a7b66f.tar.gz
linhes_pkgbuild-40c97d4ccad2d9c7dc6df0ea12ddb3c5b6a7b66f.tar.bz2
libfastjson: initial commit; dep of rsyslog
Diffstat (limited to 'abs/extra/libfastjson')
-rw-r--r--abs/extra/libfastjson/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/extra/libfastjson/PKGBUILD b/abs/extra/libfastjson/PKGBUILD
new file mode 100644
index 0000000..ab137ad
--- /dev/null
+++ b/abs/extra/libfastjson/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id$
+# Maintainer: Sergej Pupykin <arch+pub@sergej.pp.ru>
+# Maintainer: Bob Gregory <pathogenix@gmail.com>
+
+pkgname=libfastjson
+pkgver=0.99.4
+pkgrel=1
+pkgdesc="A performance-focused json library for C"
+arch=('i686' 'x86_64')
+url="https://github.com/rsyslog/libfastjson"
+license=('GPL')
+depends=()
+source=($pkgname-$pkgver.tar.gz::https://github.com/rsyslog/$pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('03ef63dcc88417e71c19ce4436804159e3397e3a20d3529efef6a43c3bef5c8d')
+
+build() {
+ cd "$pkgname-$pkgver"
+ autoreconf -fvi
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}