summaryrefslogtreecommitdiffstats
path: root/abs/extra/libftdi-compat
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-17 00:05:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:05 (GMT)
commit088c5b470b114a46fb991d99c2242f04fec0307e (patch)
tree1778e6696621d2f8115ac256f3db0ee8adcc1570 /abs/extra/libftdi-compat
parent859decb6e331f0cb49c2b2b94b0f39ed154292a4 (diff)
downloadlinhes_pkgbuild-088c5b470b114a46fb991d99c2242f04fec0307e.zip
linhes_pkgbuild-088c5b470b114a46fb991d99c2242f04fec0307e.tar.gz
linhes_pkgbuild-088c5b470b114a46fb991d99c2242f04fec0307e.tar.bz2
libftdi:
update binary path to /usr/bin refs #961
Diffstat (limited to 'abs/extra/libftdi-compat')
-rw-r--r--abs/extra/libftdi-compat/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/extra/libftdi-compat/PKGBUILD b/abs/extra/libftdi-compat/PKGBUILD
new file mode 100644
index 0000000..9be6032
--- /dev/null
+++ b/abs/extra/libftdi-compat/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 200728 2013-12-03 16:50:08Z eric $
+# Maintainer:
+
+pkgname=libftdi-compat
+pkgver=0.20
+pkgrel=1
+pkgdesc="A library to talk to FTDI chips"
+arch=('i686' 'x86_64')
+url="http://www.intra2net.com/en/developer/libftdi/download.php"
+license=('GPL2' 'LGPL2.1')
+depends=('libusb-compat' 'gcc-libs')
+makedepends=('boost')
+source=(http://www.intra2net.com/en/developer/libftdi/download/libftdi-$pkgver.tar.gz{,.sig})
+sha1sums=('4bc6ce70c98a170ada303fbd00b8428d8a2c1aa2'
+ '807d145147c9bee08b4cea4d7ca82ccaf1330f02')
+
+build() {
+ cd libftdi-$pkgver
+ ./configure --prefix=/usr --without-examples
+ make
+}
+
+package() {
+ cd libftdi-$pkgver
+ make DESTDIR="$pkgdir" install
+}