summaryrefslogtreecommitdiffstats
path: root/abs/extra/libftdi
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-17 00:05:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:05 (GMT)
commit088c5b470b114a46fb991d99c2242f04fec0307e (patch)
tree1778e6696621d2f8115ac256f3db0ee8adcc1570 /abs/extra/libftdi
parent859decb6e331f0cb49c2b2b94b0f39ed154292a4 (diff)
downloadlinhes_pkgbuild-088c5b470b114a46fb991d99c2242f04fec0307e.zip
linhes_pkgbuild-088c5b470b114a46fb991d99c2242f04fec0307e.tar.gz
linhes_pkgbuild-088c5b470b114a46fb991d99c2242f04fec0307e.tar.bz2
libftdi:
update binary path to /usr/bin refs #961
Diffstat (limited to 'abs/extra/libftdi')
-rw-r--r--abs/extra/libftdi/PKGBUILD36
1 files changed, 22 insertions, 14 deletions
diff --git a/abs/extra/libftdi/PKGBUILD b/abs/extra/libftdi/PKGBUILD
index 61165b2..76e3f58 100644
--- a/abs/extra/libftdi/PKGBUILD
+++ b/abs/extra/libftdi/PKGBUILD
@@ -1,28 +1,36 @@
-# $Id: PKGBUILD 153977 2012-03-21 07:09:24Z eric $
-# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# $Id: PKGBUILD 200729 2013-12-03 16:51:00Z eric $
+# Maintainer:
pkgname=libftdi
-pkgver=0.20
-pkgrel=1
+pkgver=1.0
+pkgrel=2
pkgdesc="A library to talk to FTDI chips"
arch=('i686' 'x86_64')
url="http://www.intra2net.com/en/developer/libftdi/download.php"
license=('GPL2' 'LGPL2.1')
-depends=('libusb-compat' 'gcc-libs')
-makedepends=('boost')
-options=('!libtool')
-source=(http://www.intra2net.com/en/developer/libftdi/download/$pkgname-$pkgver.tar.gz{,.sig})
-sha1sums=('4bc6ce70c98a170ada303fbd00b8428d8a2c1aa2'
- '807d145147c9bee08b4cea4d7ca82ccaf1330f02')
+depends=('libusbx')
+makedepends=('boost' 'cmake')
+source=(http://www.intra2net.com/en/developer/libftdi/download/${pkgname}1-$pkgver.tar.bz2{,.sig})
+sha1sums=('5be76cfd7cd36c5291054638f7caf4137303386f'
+ 'SKIP')
+
+prepare() {
+ cd ${pkgname}1-$pkgver
+ sed -i 's|LIB_SUFFIX 64|LIB_SUFFIX ""|' CMakeLists.txt
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- sed -i '/no-install/d' examples/Makefile.in
- ./configure --prefix=/usr
+ cd ${pkgname}1-$pkgver
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_SKIP_BUILD_RPATH=ON -DCMAKE_BUILD_TYPE=Release
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd ${pkgname}1-$pkgver/build
make DESTDIR="$pkgdir" install
+ find examples -type f -perm -755 -exec install {} "$pkgdir/usr/bin" \;
+ # Remove eepreom (conflict with i2c-tools FS#37925)
+ rm "$pkgdir/usr/bin/eeprom"
}