summaryrefslogtreecommitdiffstats
path: root/abs/extra/libgdiplus/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:55:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:55:44 (GMT)
commitd42ea11c01db4583efb2cb62df3d1143aa30bb51 (patch)
tree0d453029b3253ef9a37b993932b2fe30a9ce6cf6 /abs/extra/libgdiplus/PKGBUILD
parentfa28cb4fb4d3ce7ad50dd3edb3522af5d547952c (diff)
downloadlinhes_pkgbuild-d42ea11c01db4583efb2cb62df3d1143aa30bb51.zip
linhes_pkgbuild-d42ea11c01db4583efb2cb62df3d1143aa30bb51.tar.gz
linhes_pkgbuild-d42ea11c01db4583efb2cb62df3d1143aa30bb51.tar.bz2
libgdiplus 2.10
Diffstat (limited to 'abs/extra/libgdiplus/PKGBUILD')
-rw-r--r--abs/extra/libgdiplus/PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/abs/extra/libgdiplus/PKGBUILD b/abs/extra/libgdiplus/PKGBUILD
index d933fc1..84e3f45 100644
--- a/abs/extra/libgdiplus/PKGBUILD
+++ b/abs/extra/libgdiplus/PKGBUILD
@@ -1,8 +1,8 @@
-# $Id: PKGBUILD 95327 2010-10-18 17:52:42Z daniel $
+# $Id: PKGBUILD 148818 2012-02-05 11:51:42Z ibiru $
# Maintainer: Daniel Isenmann <daniel@archlinux.org>
pkgname=libgdiplus
-pkgver=2.8
+pkgver=2.10
pkgrel=2
pkgdesc="An Open Source Implementation of the GDI+ API"
arch=(i686 x86_64)
@@ -11,12 +11,19 @@ url="http://www.mono-project.com"
depends=('libtiff>=3.9.2-2' 'cairo>=1.8.10' 'giflib' 'glib2>=2.24.0' 'libexif')
makedepends=('pkgconfig')
options=('!libtool')
-source=(http://ftp.novell.com/pub/mono/sources/${pkgname}/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('4fd70e5ab7847574c20453c349bc4c97')
+source=(http://download.mono-project.com/sources/${pkgname}/${pkgname}-${pkgver}.tar.bz2 libpng15.patch)
+md5sums=('451966e8f637e3a1f02d1d30f900255d'
+ 'a2d143676bbaceeb88b4c34069e93986')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p0 <../libpng15.patch
./configure --prefix=/usr --with-cairo=system || return 1
+
make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install || return 1
}