summaryrefslogtreecommitdiffstats
path: root/abs/extra/libgdiplus
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-11 03:29:34 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-11 03:29:34 (GMT)
commit7effbc65b427f6590dd9112b1fa08b7a1c9628b4 (patch)
treeb8be85e69a43dedf92ec3d2bde72cb089667d89a /abs/extra/libgdiplus
parent49a4ccd324e2ae53c04fb5ce8b8095c6b2d5eb6a (diff)
downloadlinhes_pkgbuild-7effbc65b427f6590dd9112b1fa08b7a1c9628b4.zip
linhes_pkgbuild-7effbc65b427f6590dd9112b1fa08b7a1c9628b4.tar.gz
linhes_pkgbuild-7effbc65b427f6590dd9112b1fa08b7a1c9628b4.tar.bz2
libgdiplus: upgrade to 2.8
Diffstat (limited to 'abs/extra/libgdiplus')
-rw-r--r--abs/extra/libgdiplus/PKGBUILD20
-rw-r--r--abs/extra/libgdiplus/__changelog1
-rw-r--r--abs/extra/libgdiplus/gdiplus-png14.patch20
3 files changed, 31 insertions, 10 deletions
diff --git a/abs/extra/libgdiplus/PKGBUILD b/abs/extra/libgdiplus/PKGBUILD
index 3b91775..e55d9e6 100644
--- a/abs/extra/libgdiplus/PKGBUILD
+++ b/abs/extra/libgdiplus/PKGBUILD
@@ -1,22 +1,22 @@
-# $Id: PKGBUILD 15386 2008-10-13 16:29:55Z daniel $
-# Maintainer: daniel@archlinux.org
+# $Id: PKGBUILD 95327 2010-10-18 17:52:42Z daniel $
+# Maintainer: Daniel Isenmann <daniel@archlinux.org>
pkgname=libgdiplus
-pkgver=2.2
+pkgver=2.8
pkgrel=1
pkgdesc="An Open Source Implementation of the GDI+ API"
arch=(i686 x86_64)
license=('MPL' 'LGPL')
url="http://www.mono-project.com"
-depends=('libtiff' 'cairo>=1.6.4' 'giflib' 'glib2>=2.18.0' 'libexif')
-makedepends=('automake' 'pkgconfig')
+depends=('libtiff>=3.9.2-2' 'cairo>=1.8.10' 'giflib' 'glib2>=2.24.0' 'libexif')
+makedepends=('pkgconfig')
options=('!libtool')
-source=(http://go-mono.com/sources/${pkgname}/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('4af9c8171e75f1408c3628a8f7937d9f')
+source=(http://ftp.novell.com/pub/mono/sources/${pkgname}/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('4fd70e5ab7847574c20453c349bc4c97')
build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
- ./configure --prefix=/usr --with-cairo=system
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --with-cairo=system || return 1
make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
+ make DESTDIR="${pkgdir}" install || return 1
}
diff --git a/abs/extra/libgdiplus/__changelog b/abs/extra/libgdiplus/__changelog
new file mode 100644
index 0000000..aecc073
--- /dev/null
+++ b/abs/extra/libgdiplus/__changelog
@@ -0,0 +1 @@
+update to 2.8
diff --git a/abs/extra/libgdiplus/gdiplus-png14.patch b/abs/extra/libgdiplus/gdiplus-png14.patch
new file mode 100644
index 0000000..d132608
--- /dev/null
+++ b/abs/extra/libgdiplus/gdiplus-png14.patch
@@ -0,0 +1,20 @@
+--- src/pngcodec.c.orig 2010-01-16 23:47:17.000000000 +0100
++++ src/pngcodec.c 2010-01-16 23:49:49.000000000 +0100
+@@ -352,7 +352,7 @@
+ info_ptr->palette[i].blue,
+ info_ptr->palette[i].green,
+ info_ptr->palette[i].red,
+- info_ptr->trans[i]); /* alpha */
++ info_ptr->trans_alpha[i]); /* alpha */
+ }
+ }
+
+@@ -418,7 +418,7 @@
+ }
+
+ if ((color_type == PNG_COLOR_TYPE_GRAY) && (bit_depth < 8)) {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ }
+
+ if (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)) {