summaryrefslogtreecommitdiffstats
path: root/abs/extra/libimobiledevice/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2012-04-07 21:03:06 (GMT)
committerBritney Fransen <brfransen@gmail.com>2012-04-07 21:03:06 (GMT)
commit9fcaf97deafe261e47a41039f8571896deb6489d (patch)
treee169d2f3369e5c6a9887f24b57bc07f955bf0209 /abs/extra/libimobiledevice/PKGBUILD
parentfacd9e282bbe154047eb9efa7294db4b1a2fbe0a (diff)
downloadlinhes_pkgbuild-9fcaf97deafe261e47a41039f8571896deb6489d.zip
linhes_pkgbuild-9fcaf97deafe261e47a41039f8571896deb6489d.tar.gz
linhes_pkgbuild-9fcaf97deafe261e47a41039f8571896deb6489d.tar.bz2
libimobiledevice: Initial inclusion; dep of upower
Diffstat (limited to 'abs/extra/libimobiledevice/PKGBUILD')
-rw-r--r--abs/extra/libimobiledevice/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra/libimobiledevice/PKGBUILD b/abs/extra/libimobiledevice/PKGBUILD
new file mode 100644
index 0000000..81a8003
--- /dev/null
+++ b/abs/extra/libimobiledevice/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Gabriel Martinez < reitaka at gmail dot com >
+
+pkgname=libimobiledevice
+pkgver=1.1.1
+pkgrel=3
+pkgdesc="Is a software library that talks the protocols to support iPhone and iPod Touch devices on Linux"
+url="http://libimobiledevice.org/"
+arch=('i686' 'x86_64')
+license=('GPL2' 'LGPL2.1')
+depends=('usbmuxd' 'libplist' 'gnutls' 'libgcrypt')
+makedepends=('python2' 'swig')
+options=('!libtool')
+source=(http://libimobiledevice.org/downloads/$pkgname-$pkgver.tar.bz2
+ swig-version-check.patch)
+md5sums=('cdc13037e822d9ac2e109536701d153a'
+ '8bb215e36fe0e08a72332c108c7842cc')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ # SWIG version check is wrong (still not fixed upstream)
+ patch -p1 -i ../swig-version-check.patch
+
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}