summaryrefslogtreecommitdiffstats
path: root/abs/extra/libinput
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-16 23:07:43 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-16 23:07:43 (GMT)
commitb8bd809fca6627a65c435b3322c7b4a7859e0d04 (patch)
tree6f928b509437d0413063974b56b12100a2d0218c /abs/extra/libinput
parent1d82e9803e355eefc7f4db47ecc4b0a2c88ea27f (diff)
downloadlinhes_pkgbuild-b8bd809fca6627a65c435b3322c7b4a7859e0d04.zip
linhes_pkgbuild-b8bd809fca6627a65c435b3322c7b4a7859e0d04.tar.gz
linhes_pkgbuild-b8bd809fca6627a65c435b3322c7b4a7859e0d04.tar.bz2
libinput: initial inclusion. dep of qt5
Diffstat (limited to 'abs/extra/libinput')
-rw-r--r--abs/extra/libinput/PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/abs/extra/libinput/PKGBUILD b/abs/extra/libinput/PKGBUILD
new file mode 100644
index 0000000..1d39dd9
--- /dev/null
+++ b/abs/extra/libinput/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id$
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Maintainer: Jan de Groot
+
+pkgname=libinput
+pkgver=1.1.4
+pkgrel=1
+pkgdesc="library that handles input devices for display servers and other applications that need to directly deal with input devices."
+arch=(i686 x86_64)
+url="http://www.freedesktop.org/wiki/Software/libinput/"
+license=(custom:X11)
+depends=('mtdev' 'systemd' 'libevdev')
+install=libinput.install
+options=('!libtool')
+source=(http://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz{,.sig})
+sha256sums=('302cb76209b9c57a5a318e178f9bc446eede8ea79386103b5291cbfaa5fab5b6'
+ 'SKIP')
+validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
+
+prepare() {
+ cd $pkgname-$pkgver
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver
+ make check
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}