summaryrefslogtreecommitdiffstats
path: root/abs/extra/libmpdclient
diff options
context:
space:
mode:
authorJames Meyer <jams@linhes.org>2010-12-22 19:54:09 (GMT)
committerJames Meyer <jams@linhes.org>2010-12-22 19:54:09 (GMT)
commitf11f722e4d91aca54bd4b7b04330201a0787e3df (patch)
tree952050d92b790dde5f5dd619cf7bd8808492f437 /abs/extra/libmpdclient
parent51d7490509b3908658953e62c5c16c26370f495c (diff)
downloadlinhes_pkgbuild-f11f722e4d91aca54bd4b7b04330201a0787e3df.zip
linhes_pkgbuild-f11f722e4d91aca54bd4b7b04330201a0787e3df.tar.gz
linhes_pkgbuild-f11f722e4d91aca54bd4b7b04330201a0787e3df.tar.bz2
mpd/mpc/libmpdclient: add mpd and simple client
refs:#741
Diffstat (limited to 'abs/extra/libmpdclient')
-rw-r--r--abs/extra/libmpdclient/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/extra/libmpdclient/PKGBUILD b/abs/extra/libmpdclient/PKGBUILD
new file mode 100644
index 0000000..84ecda6
--- /dev/null
+++ b/abs/extra/libmpdclient/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 50625 2009-08-30 03:02:23Z allan $
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=libmpdclient
+pkgver=2.3
+pkgrel=1
+pkgdesc="An asynchronous API library for interfacing MPD in the C, C++ & Objective C languages"
+arch=('i686' 'x86_64')
+url="http://mpd.wikia.com/wiki/ClientLib:libmpdclient"
+license=('GPL2')
+depends=('glibc')
+options=('!libtool')
+source=("http://downloads.sourceforge.net/musicpd/${pkgname}-${pkgver}.tar.bz2")
+sha1sums=('d1ccd40f1c7a723ef0a8eb0e19b51699ec9a8f9e')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}