summaryrefslogtreecommitdiffstats
path: root/abs/extra/libnotify
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:58:13 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:58:13 (GMT)
commit3ee5ce3c81de7d50a8a245133758ade323f0b5da (patch)
tree1cb800916bf209d43cbcb265a5064cd8f9ae9492 /abs/extra/libnotify
parent72dc9ab02eaa403691ae04a7f3111b12b1dd12d0 (diff)
downloadlinhes_pkgbuild-3ee5ce3c81de7d50a8a245133758ade323f0b5da.zip
linhes_pkgbuild-3ee5ce3c81de7d50a8a245133758ade323f0b5da.tar.gz
linhes_pkgbuild-3ee5ce3c81de7d50a8a245133758ade323f0b5da.tar.bz2
libnotify: 0.7.5
Diffstat (limited to 'abs/extra/libnotify')
-rw-r--r--abs/extra/libnotify/PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/abs/extra/libnotify/PKGBUILD b/abs/extra/libnotify/PKGBUILD
index dd37ce8..b0af725 100644
--- a/abs/extra/libnotify/PKGBUILD
+++ b/abs/extra/libnotify/PKGBUILD
@@ -1,21 +1,26 @@
-# $Id: PKGBUILD 99716 2010-11-16 22:24:02Z ibiru $
+# $Id: PKGBUILD 154761 2012-03-30 16:37:09Z heftig $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=libnotify
-pkgver=0.5.2
+pkgver=0.7.5
pkgrel=1
pkgdesc="Desktop notification library"
-arch=(i686 x86_64)
-url="http://www.galago-project.org/"
+arch=('i686' 'x86_64')
+url="http://library.gnome.org/devel/notification-spec/"
license=('LGPL')
-depends=('dbus-glib>=0.92' 'gtk2>=2.22.1')
+depends=('gdk-pixbuf2')
+makedepends=('gtk3' 'gobject-introspection')
options=('!libtool')
-source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/0.5/${pkgname}-${pkgver}.tar.bz2)
-sha256sums=('1f6f1a2d6a0e009997c7ed31f6197f9bf09e9b45fb9cd54acabceea951d99062')
+source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/0.7/${pkgname}-${pkgver}.tar.xz)
+sha256sums=('4378cb47874ba4d5f759b7890d8d28d086e81d3f0bd4f6e84e5ab66d82ffb652')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --disable-static
- make
- make DESTDIR="${pkgdir}" install
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
}