summaryrefslogtreecommitdiffstats
path: root/abs/extra/libproxy/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-12 20:20:23 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-12 20:20:23 (GMT)
commit574bd3bd42c540d3e502e8915c010f87f97e450e (patch)
tree702f203bf81084efa8196e9ea1ea962f1c4c5dff /abs/extra/libproxy/PKGBUILD
parent4bc276c90ebb0a0cd5c3d17c1ea2d51508d46792 (diff)
downloadlinhes_pkgbuild-574bd3bd42c540d3e502e8915c010f87f97e450e.zip
linhes_pkgbuild-574bd3bd42c540d3e502e8915c010f87f97e450e.tar.gz
linhes_pkgbuild-574bd3bd42c540d3e502e8915c010f87f97e450e.tar.bz2
libproxy: update to 0.4.11
Diffstat (limited to 'abs/extra/libproxy/PKGBUILD')
-rw-r--r--abs/extra/libproxy/PKGBUILD34
1 files changed, 13 insertions, 21 deletions
diff --git a/abs/extra/libproxy/PKGBUILD b/abs/extra/libproxy/PKGBUILD
index 9fb8e85..70a1362 100644
--- a/abs/extra/libproxy/PKGBUILD
+++ b/abs/extra/libproxy/PKGBUILD
@@ -1,32 +1,22 @@
-# $Id: PKGBUILD 24494 2009-01-17 20:42:01Z jgc $
+# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=libproxy
-pkgver=0.4.7
-pkgrel=2
+pkgver=0.4.11
+pkgrel=4
pkgdesc="A library that provides automatic proxy configuration management"
arch=(i686 x86_64)
license=('LGPL')
depends=('gcc-libs')
-optdepends=('kdelibs: KDE configuration module'
- 'networkmanager: NetworkManager configuration module'
- 'perl: Perl bindings'
- 'python2: Python bindings')
-makedepends=('cmake' 'automoc4' 'python2' 'perl')
+optdepends=('perl: Perl bindings'
+ 'python2: Python bindings'
+ 'glib2: gsettings configuration module')
+makedepends=('cmake' 'python2' 'perl')
url="http://libproxy.googlecode.com"
-source=(http://libproxy.googlecode.com/files/${pkgname}-${pkgver}.tar.gz
- libproxy-0.4.7-unistd.patch)
-options=('!libtool')
-md5sums=('509e03a488a61cd62bfbaf3ab6a2a7a5'
- 'e90c03f296e553ace347b46f4fea3625')
+source=(http://libproxy.googlecode.com/files/${pkgname}-${pkgver}.tar.gz)
+md5sums=('3cd1ae2a4abecf44b3f24d6639d2cd84')
build() {
- cd "${srcdir}"
-
- # Fix build with GCC 4.7 (patch from Fedora)
- patch -d "${pkgname}-${pkgver}" -Np1 -i \
- "${srcdir}/libproxy-0.4.7-unistd.patch"
-
mkdir build
cd build
cmake ../${pkgname}-${pkgver} \
@@ -37,11 +27,13 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DWITH_WEBKIT=OFF \
-DCMAKE_CXX_FLAGS="${CXXFLAGS}" \
- -DCMAKE_C_FLAGS="${CFLAGS}"
+ -DCMAKE_C_FLAGS="${CFLAGS}" \
+ -DWITH_KDE4=OFF \
+ -DPYTHON_EXECUTABLE:FILEPATH=/usr/bin/python2
make
}
package() {
- cd "${srcdir}/build"
+ cd build
make DESTDIR="${pkgdir}" install
}