summaryrefslogtreecommitdiffstats
path: root/abs/extra/libraqm
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-15 21:59:28 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-15 21:59:28 (GMT)
commit773838472d40fd47b6aa5048ecd4fe7cec77b527 (patch)
tree07023049f1d92330eb71ae689a9227689ca647ce /abs/extra/libraqm
parentbcb357cc50a5637a1f354ce1430e2519644da024 (diff)
downloadlinhes_pkgbuild-773838472d40fd47b6aa5048ecd4fe7cec77b527.zip
linhes_pkgbuild-773838472d40fd47b6aa5048ecd4fe7cec77b527.tar.gz
linhes_pkgbuild-773838472d40fd47b6aa5048ecd4fe7cec77b527.tar.bz2
libraqm: initial inclusion. dep of imagemagick6
Diffstat (limited to 'abs/extra/libraqm')
-rw-r--r--abs/extra/libraqm/PKGBUILD36
-rw-r--r--abs/extra/libraqm/__changelog1
2 files changed, 37 insertions, 0 deletions
diff --git a/abs/extra/libraqm/PKGBUILD b/abs/extra/libraqm/PKGBUILD
new file mode 100644
index 0000000..6cc03b9
--- /dev/null
+++ b/abs/extra/libraqm/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer:
+# Contributor: Daniel Bermond < yahoo-com: danielbermond >
+
+pkgname=libraqm
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='A library that encapsulates the logic for complex text layout'
+arch=(x86_64)
+url='https://github.com/HOST-Oman/libraqm/'
+license=(MIT)
+depends=(freetype2 fribidi)
+makedepends=(gtk-doc)
+source=(https://github.com/HOST-Oman/libraqm/releases/download/v$pkgver/raqm-$pkgver.tar.gz)
+sha256sums=('f90f79c4d055453d692d45255843589e502d10c83665715c1fc0ed9a1fd0d522')
+
+build() {
+ cd raqm-$pkgver
+
+ ./configure \
+ --prefix=/usr \
+ --enable-static=no \
+ --enable-shared=yes \
+ --enable-fast-install=yes \
+ --enable-gtk-doc=no \
+ --enable-gtk-doc-html=no \
+ --enable-gtk-doc-pdf=no
+ make
+}
+
+package() {
+ cd raqm-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ install -D -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/abs/extra/libraqm/__changelog b/abs/extra/libraqm/__changelog
new file mode 100644
index 0000000..e8bcfcf
--- /dev/null
+++ b/abs/extra/libraqm/__changelog
@@ -0,0 +1 @@
+PKGBUILD: don't build docs